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Introducing the Intel® Parallel Inspector

The Intel® Parallel Inspector is a serial and multithreading error checking analysis tool for Microsoft Visual Studio*
C/C++ developers. The Inspector detects challenging memory leaks and corruption errors as well as threading
data races and deadlock errors. This comprehensive developer productivity tool pinpoints errors and provides
guidance to help ensure application reliability and quality.

The Inspector currently supports applications:
e Created with C/C++ code
e Developed in the Visual Studio* 2005/2008/2010 IDE

e Using the Intel® Threading Building Blocks, Intel® Cilk™ Plus, Windows* API, or OpenMP* API programming
models

e Developed to run on the Windows* operating systems listed in Release Notes.

Inspector Tutorials

These tutorials tell you how to use the Inspector to find and fix memory errors in serial or parallel applications,
and find and fix threading errors in parallel applications.

e Managing Memory Errors
e Managing Threading Errors
Check http://software.intel.com/en-us/articles/intel-software-product-tutorials/ for the following:

e Printable version (PDF) of all Inspector tutorials

¢ Show Me Video of each Inspector tutorial

See Also
e Getting Help
e More Resources
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Prerequisites

You need the following tools, skills, and knowledge to effectively use these tutorials.

NOTE. The steps and screen captures in these tutorials are based on the Visual Studio* 2005 IDE.
They may differ slightly for other versions of the Visual Studio* IDE.

Required Tools
You need the following tools to use these tutorials:

e Inspector
e Sample code shipped with the Inspector
e Inspector Help

e Supported compiler (see Release Notes for more information)

To acquire the Inspector:

If you do not already have access to the Inspector, you can download an evaluation copy from
http://software.intel.com/en-us/intel-parallel-studio-home/

To install and set up Inspector sample code:

1. Copy the t achyon_st udi o. zi p file from the Sanpl es\ <l ocal e> folder in the Parallel Studio installation
folder (the default installation folder is C:\ Program Fil es\Intel\Paral l el Studi o 2011) to a writable
directory or share on your system.

2. Extract the sample(s) from the . zi p file.

NOTE.

e Samples are non-deterministic. Your screens may vary from the screen captures shown
throughout these tutorials.

e Samples are designed only to illustrate Inspector features and do not represent best practices
for creating multithreaded code.

To access Inspector Help:

See Getting Help




Intel® Parallel Inspector 2011 Getting Started Tutorials

Required Skills and Knowledge

These tutorials are designed for developers with a basic understanding of the Visual Studio* 2005 development
environment (IDE), including how to:

e Open a project/solution.

e Display the Solution Explorer.

e Compile and link an application.

e Ensure an application compiled successfully.

e Access the Document Explorer window.
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Navigation Quick Start

Inspector/Visual Studio* 2005 Integration

The Inspector integrates into the Visual Studio* development environment (IDE) and can be accessed from the
menus, toolbar, and Solution Explorer in the following manner:

Use the Tools > Intel Parallel Inspector 2011 menu to control result collection.
Use the Inspector toolbar to control result collection.

Solution Explorer pop-up menus and folders:
e Use the Intel Parallel Inspector 2011 menu on the Solution Explorer project pop-up menu
to control result collection.

e Use the pop-up menu on results in the My Inspector Results folder to manage previously
collected results.

11
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Use the Inspector result tabs to manage result data.
Use the Dynamic Help window to access help topics related to the current Inspector window.

Use the Output window to view application execution and analysis output.

Inspector Result Tabs

Use result tab names to distinguish among results.

Click the B icon to display a help snippet and provide links to more help information. (You can
also press the F1 key to display more complete help topics and links.)

Click buttons on the navigation toolbar to change window views.

Click buttons to display help pages that describe how to use window panes.
Use window panes to manage result data.

Use title bars to identify window panes.

Drag window pane borders to resize window panes.

12



Navigation Quick Start

Click ===, 1 e, r:, and _ icons to toggle window panes on and off.

Data column headers - Drag to reposition the data column; drag the left or right border to resize
the data column; click to sort results in ascending or descending order by column data.

Right-click data in window panes to display pop-up menus that provide access to key capabilities.

13
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Tutorial: Managing Memory Errors

Learning Objectives

This tutorial shows how to use the Intel® Parallel Inspector to identify, analyze, and resolve memory errors.

Estimated completion time: 10 - 15 minutes.

NOTE. This tutorial does not require prior completion of other tutorials. Consequently, some terms,
concepts, and workflow steps are common to all tutorials.

After you complete this tutorial, you should be able to:

e List, in order, the steps to manage memory errors.

e Define key Inspector terms, such as analysis, result, problem set, problem, and observation.
e Identify compiler/linker options that produce the most accurate, complete analysis results.
¢ Explain how data set size impacts application execution time and analysis speed.

e Run memory error analyses.

e Influence analysis scope and running time.

e Access help for the Inspector command-line interface.

¢ Navigate among windows in Inspector results.

e Display a prioritized to-do list for resolving errors.

e Access help for resolving specific errors.

e Access source code to fix errors.

Key Terms and Concepts

Key Terms
analysis: A process during which the Inspector performs collection and finalization.

collection: A process during which the Inspector executes an application, identifies issues that may need
handling, and collects those issues in a result.

false positive: The Inspector detects something that is not an error.

15



1 Intel® Parallel Inspector 2011 Getting Started Tutorials

false negative: The Inspector does not detect an error because the problem may be too complex/big or involve
too much runtime/memory cost.

finalization: A process during which the Inspector uses debug information from binary files to convert symbol
information into filenames and line numbers, perform duplicate elimination, and form problem sets.

observation: A fact the Inspector observes at a source code location, such as a write observation. A focus
observation is a source code location with relationships you choose to explore. A related observation is a source
code location with a relationship to a focus observation and possibly other observations.

problem: A small group of closely related observations (source code locations) that indicate an error in an
application, such as a data race problem.

problem set: A larger group of more loosely related observations (source code locations) that could share a
common solution, such as a problem set resulting from deallocating an object too early during program execution.
You can view problem sets only after analysis is complete.

project: A compiled application, collection of configurable attributes surrounding the compiled application, and
a container for results.

result: A collection of issues that may need handling.

target: An application you inspect for errors using the Inspector.

Key Concept: Choosing Small, Representative Data Sets

When you run a dynamic analysis, the Inspector executes an application against a data set. Data set size has
a direct impact on application execution time and analysis speed.

For example, it takes longer to process a 1000x1000 pixel image than a 100x100 pixel image. A possible reason:
You may have loops with an iteration space of 1...1000 for the larger image, but only 1...100 for the smaller
image. The exact same code paths may be executed in both cases. The difference is the number of times these
code paths are repeated.

You can control analysis cost without sacrificing completeness by removing this kind of redundancy from your
data set.

Instead of choosing large, repetitive data sets, choose small, representative data sets. Data sets with runs in
the seconds time range are ideal. You can always create additional data sets to ensure all your code is inspected.

Key Concept: Choosing Analysis Type Configurations

The Inspector offers preset memory and threading configurations to help you control analysis scope and cost.

Preset Advantages Disadvantages
Configurations
Narrowest scope ¢ Minimizes the load on the system. e Detects only simple errors.

¢ Minimizes the time required to perform | ¢ Provides no details.
the analysis.

¢ Increases the chances the analysis will
complete successfully - particularly on
large applications/large data sets.

16



Tutorial: Managing Memory Errors 1

Preset
Configurations

Advantages

Disadvantages

Intermediate
scope(s)

¢ Detects important errors.

e Provides some context and detail for
detected errors.

¢ Increases the load on the system.

¢ Increases the time required to perform
the analysis.

¢ Increases the chances the analysis will
fail because the system may run out of
resources.

Widest scope

¢ Detects important errors.

e Provides context and maximum amount
of detail for detected errors.

¢« Maximizes the load on the system.

e Maximizes the time required to perform
the analysis.

¢ Maximizes the chances the analysis will
fail because the system may run out of
resources.

For more details, check the Inspector Help Index for configuration.

Workflow Steps to Identify, Analyze, and Resolve Memory Errors

You can use the Inspector to identify, analyze, and resolve memory errors in serial or parallel programs by
performing a series of steps in a workflow. This tutorial guides you through these workflow steps using
t achyon_st udi o sample code.

NOTE. Click

for a video demonstration. Show Me Videos require Adobe* Flash* Player.

17
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. Choose a project.

. Verify settings and build an application to inspect for errors.
. Configure a memory error analysis.

. Run the memory error analysis on the application.

. Choose a problem set in the analysis result.

. Interpret the result data.

. Resolve the issue.

. Resolve the next issue.

O 0O NGO UL A WN R

. Rebuild the application and rerun the memory error analysis.

Choose Project

To enable Inspector functionality:

e Open a Visual Studio* solution.

e Set a startup project.

To open a Visual Studio* solution:

1. From the Visual Studio* menu, choose File > Open > Project/Solution.

2. In the Open Project dialog box, open the t achyon_st udi o\ vc8\t achyon_Par al | el St udi o. sl n file to
display the tachyon_ParallelStudio solution in the Solution Explorer:

18



Tutorial: Managing Memory Errors 1

NOTE. See Prerequisites to locate and extract the *. sl n file.

To choose a startup project:

1. Right-click the find_and_fix_memory_errors project.
2. Choose Set as Startup Project:

19
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Recap

You chose the find_and_fix_memory_errors project.

Key Terms and Concepts

e Concept: Choosing Small, Representative Data Sets

Build Application

You can use the Inspector on both debug and release modes of binaries containing native code; however, projects
compiled/linked in debug mode using the following options produce the most accurate, complete results.

Compiler/Linker Options Correct Setting Impact If Not Set Correctly

Debug information Enabled (/ Zi or/Zl) Missing file/line information

Optimization Disabled (/ ) Incorrect file/line information

Dynamic runtime library Selected (/ MD or / M) False positives or missing
observations

To enable correct analysis of Intel® Threading Building Blocks (Intel® TBB) applications, you must also set the
following required macros before compiling:

e TBB_USE_DEBUG (which sets TBB_USE_THREADING_TOOLS) if you use Intel® TBB debug libraries

e TBB_USE_THREADING_TOOLS if you use Intel® TBB release libraries

The impact if not set correctly: Intel Inspector XE may generate false positives. See Intel® TBB documentation
for more information.

To create an application the Inspector can inspect for memory errors:

¢ Verify debug mode is configured to produce the best results.

e Verify the application is set to build in debug mode.

e Build the application.

To verify debug mode is configured to produce the best resulits:

1. Right-click the find_and_fix_memory_errors project in the Solution Explorer.
2. Choose Properties to display the Property Pages dialog box.
3. Verify the Configuration drop-down list is set to Debug or Active(Debug).

20



Tutorial: Managing Memory Errors 1

4. In the left pane, choose Configuration Properties > C/C++ > General.

5. Verify the Debug Information Format is set to Program Database (/Zi) or Program Database for Edit
& Continue (/ZI).

6. In the left pane, choose Configuration Properties > C/C++ > Optimization.
7. Verify the Optimization field is set to Disabled (/0d).

21
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8. In the left pane, choose Configuration Properties > C/C++ > Code Generation.

9. Verify the Runtime Library field is set to Multi-threaded DLL (/MD) or Multi-threaded Debug DLL
(/MDd).

10 In the left pane, choose Configuration Properties > Linker > Debugging.
11. Verify the Generate Debug Info field is set to Yes (/DEBUG).

22



Tutorial: Managing Memory Errors 1

To verify the application is set to build in debug mode:

1. Click the Configuration Manager button.
2. Verify the Active solution configuration drop-down list is set to Debug.

3. Click the Close button to close the Configuration Manager dialog box.
4. Click the OK button to close the Property Pages dialog box.

To build the application:

23
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1. From the Visual Studio* menu, choose Debug > Start Without Debugging
2. If the Visual Studio* IDE responds any projects are out of date, click Yes to build.
3. Check for a display similar to the following:

Notice the application output window is empty. The cause: Memory errors. This is how the application output
should look after various memory errors are resolved:

Recap

You verified the find_and_fix_memory_errors project is set to produce the most accurate, complete results;
compiled and linked the application; and ensured the resulting fi nd_and_fi x_nmenory_errors. exe file runs
on your system outside the Inspector.

Key Terms and Concepts

e Term: False negative

e Term: False positive

24



Tutorial: Managing Memory Errors 1

Configure Analysis

Choose a preset configuration to influence memory error analysis scope and running time.

To configure a memory error analysis:

1. From the Visual Studio* menu, choose Tools > Intel Parallel Inspector 2011 > Inspect Memory Errors
to display the Configure Analysis dialog box:

The Analysis type drop-down list shows Inspector dynamic analysis type offerings: Memory
error analysis and threading error analysis.

This tutorial covers memory error analyses, which you can use to search for these kinds of
errors: GDI resource leak, kernel resource leak, invalid memory access, memory leak, mismatched
allocation/deallocation, missing allocation, and uninitialized memory access.

Use threading error analyses to search for these kinds of errors: Data race, deadlock, lock
hierarchy violation, and cross-thread stack access.

25
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The Analysis Time Overhead gauge shows the time it may take to collect a result at each
preset configuration. Time is expressed in relation to normal application execution time. For
example, 2x - 20x is 2 to 20 times longer than normal application execution time. If normal
application execution time is 5 seconds, estimated collection time is 10 to 100 seconds.

Here, the configuration slider rests at the Does my target leak memory? preset configuration,
which has the narrowest scope/lowest overhead. Try dragging the configuration slider to see
the impact on the gauge.

The configuration details region shows current configuration characteristics. Try dragging the
configuration slider to see the impact on the details region.

Suppressing known issues can dramatically improve your productivity. For more details, check
the Inspector Help Index for suppression rule.

2. Drag the configuration slider to the Does my target have memory access problems? preset configuration:

Recap

You chose a preset configuration of intermediate scope to detect memory errors in the
find_and_fix_nenory_errors. exe file.
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Tutorial: Managing Memory Errors 1

Key Terms and Concepts

Term: Analysis

Term: Target

Concept: Choosing Analysis Type Configurations

Run Analysis

Run a memory error analysis to detect memory errors that may need handling.

To run a memory error analysis:

Click the Run Analysis button on the Configure Analysis dialog box to:

Execute the fi nd_and_fi x_menory_errors. exe file.
Identify memory errors that may need handling.
Collect the result in a folder in the t achyon_st udi o\ vc8\ I nspector\ My | nspector Results folder.

Finalize the result (convert symbol information into filenames and line numbers, perform duplicate elimination,
and form problem sets).

During collection, the Inspector displays a Collection Log window similar to the following:

The Visual Studio* IDE offers a pointer to the result from the Solution Explorer to provide easy
future access. Here, the Visual Studio* IDE created a find_and_fix_memory_errors\My
Inspector Results folder in the Solution Explorer with a pointer to the ro00mi2 result.

27
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The result name appears in the tab. Here, the name of the result (and the name of the result folder
in the t achyon_st udi o\ vc8\ I nspector\ My | nspector Resul ts folder) is r 000m 2, where:

e r = constant
e 000 = next available number
e m = memory error analysis type

e 2 = preset configuration of intermediate scope

The Collection Log pane shows detected problems in real time.

This tutorial does not cover examining and solving problems during collection. For more details,
check the Inspector Help Index for examine result during analysis.

The Visual Studio* Output window shows Inspector analysis status messages.

If necessary, choose Intel Parallel Inspector messages in the Show output from drop-down
list to see the status messages.

The Interpret Result button displays after analysis (both collection and finalization) completes
successfully.

You can examine and solve problems during collection - and continue to examine and solve problems
after collection and finalization are complete - but there are trade-offs involved.

ﬂ TIP. Wait until analysis is complete, then click the Interpret Result button to use the
full range of Inspector capabilities to manage result data in a more efficient, effective,
and productive manner.

NOTE. This tutorial explains how to run an analysis from the Inspector graphical user interface
(GUI). You can also use the Inspector command-line interface (i nsp-cl command) to run an
analysis. For more details, check the Inspector Help Index for insp-c/ command.

To start managing result data after analysis is complete:
Click the Interpret Result button to display the Overview window:

28



Tutorial: Managing Memory Errors 1

Recap
You inspected the fi nd_and_fi x_nmenory_errors. exe application for memory errors, during which:

e The Inspector ran the fi nd_and_fi x_nenory_errors. exe file, identified memory errors that may need
handling, collected a result in the t achyon_st udi o\ vc8\ I nspector\ My | nspector Results\r000mni 2
folder, converted symbol information into filenames and line numbers, performed duplicate elimination, and
formed problem sets.

¢ The Visual Studio* IDE added a pointer to the r 000m 2 result from the Solution Explorer.

Key Terms and Concepts

e Term: Analysis

e Term: Collection

e Term: Finalization
e Term: Problem Set

e Term: Result

Choose Problem Set

To start exploring a detected memory error:

e Interpret the window.
¢ Choose a problem set.

29
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To interpret the Overview window:

The Overview window is the default starting point for managing result data. It groups observations
into problem sets, and then prioritizes the problem sets by severity and size.

The Details window is the advanced starting point for managing result data - it does not group
observations into problem sets. This tutorial does not cover searching for observations that answer
specific questions only you can formulate. For more details, check the Inspector Help Index for
select/observation search criteria.

The arrows in the Navigation toolbar indicate you can access the Sources window from both the
Overview and Details windows.

Think of the Problems pane as a to-do list. Start at the top and work your way down.

The Code Locations in Problem(s) pane shows all the observations in all the problems in the
selected problem set. By default, the Inspector selects the first problem set for you.

Here, the Inspector selected the Mismatched allocation/deallocation problem set, which contains
one problem composed of an Allocation site and Mismatched deallocation site observation in
the find_and_fix_menory_errors. cpp source file.

The Filters pane (toggled off by default) categorizes all displayed problem sets by specific criteria.
Use it to temporarily limit the list in the Problems pane to only those problem sets that meet
specific criteria.

This tutorial does not cover searching for specific problem sets. For more details, check the Inspector
Help Index for select/problem set search criteria.

To choose a problem set:
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Tutorial: Managing Memory Errors 1

Double-click the data row for the Mismatched allocation/deallocation problem set to display the Sources
window, which provides more visibility into the error:

Recap

You started exploring a Mismatched allocation/deallocation problem set that contains one problem composed
of an Allocation site and a Mismatched deallocation site observation.

Key Terms and Concepts

e Term: Observation
e Term: Problem
e Term: Problem set

e Term: Result

Interpret Result Data

To determine the cause of the detected memory error:

e Interpret the window.

e Interpret window icons.

e Understand the issue.

e Access more information on interpreting and resolving problems.

To interpret the Sources window:
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Like the pane on the Overview window, the Code Locations in Problem(s) pane shows all the
observations in the Mismatched allocation/deallocation problem in the Mismatched
allocation/deallocation problem set.

The Allocation site observation represents the location and associated call stack from which the
memory block was allocated. The Mismatched deallocation site observation represents the
location and associated call stack attempting the deallocation.

The Relationships pane shows the relationship between the Allocation site and Mismatched
deallocation site observations in the Mismatched allocation/deallocation problem. In
relationship diagrams:

e Each box in a diagram represents an observation in one problem in a problem set.
e A diagram with a single box is a trivial problem with no related observation.
e Vertically stacked boxes indicate concurrent observations.

¢ Boxes arranged left-to-right with connecting arrows indicate a time ordering. Here, the Allocation
site observation occurs before the Mismatched deallocation site observation.

e Boxes with connecting lines indicate association.

The Related Code Location pane shows the source code in the
find_and_fix_nenory_errors. cpp source file surrounding the Allocation site observation.
(Notice the F icon in the pane title matches the F icon on the Allocation site observation data
row in the Code Locations in Problem(s) pane.) The source code corresponding to the Allocation
site observation is highlighted.
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Tutorial: Managing Memory Errors 1

The Focus Code Location pane shows the source code inthefind_and_fi x_nenory_errors. cpp
source file surrounding the Mismatched deallocation site observation. (Notice the B icon in the
pane title matches the B icon on the Mismatched deallocation site observation data row in the
Code Locations in Problem(s) pane.) The source code corresponding to the Mismatched
deallocation site observation is highlighted.

To interpret window icons:

Icon Meaning
E) This observation is the focus observation. The Inspector chose it | Observation source code is
for you when you double-clicked the Mismatched available for viewing in the

allocation/deallocation problem set on the Overview window. | Inspector and editing in the
Its source code is currently displayed in the Focus Code Location | Visual Studio* editor.
pane.

B This observation is related to the focus observation. Its source
code is currently displayed in the Related Code Location pane.

To understand the issue:
Look at the code in the Focus Code Location pane and the Related Code Location pane.

The code in the Allocation site observation in the Related Code Location pane contains a new allocator, while
the code in the Mismatched deallocation site observation in the Focus Code Location pane containsafree()
deallocator.

A Mismatched allocation/deallocation problem occurs when you attempt a deallocation with a function that
is not the logical reflection of the allocator. In the C++ programming language, the following are matched
reflections:

e newanddel ete

e new] and del ete[]

e malloc() andfree()

Only the matching deallocation technique is uniquely aware of all the memory allocation techniques and internal

data storage used by the allocation technique. Using the wrong deallocation technique will almost certainly
corrupt memory reclamation, its sole job.

NOTE. A Mismatched allocation/deallocation problem does not always cause an application
crash; however, if it does cause a crash, the crash may occur later at a seemingly unrelated location.

To access more information on interpreting and resolving problems:

1. Right-click any observation in the Code Locations in Problem(s) pane or box in the Relationships pane.

2. Choose Explain Problem to display Inspector Help information for the Mismatched allocation/deallocation
problem type.

Recap

You determined the cause of the Mismatched allocation/deallocation problem set in the
find_and_fix_nenory_errors. cpp source file: newand f r ee are not matching techniques.
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Key Terms and Concepts

e Term: Observation

e Term: Problem

e Term: Problem set

e Term: Related observation

e Term: Result

Resolve Issue

Access the Visual Studio* editor to fix the memory error.

To resolve the issue:

1. Double-click the highlighted code in the Focus Code Location pane to open the
find_and_fix_nenmory_errors. cpp source file in a separate tab where you can edit it with the Visual Studio*
editor:

2. Comment free(draw ng); and uncomment//del ete draw ng;:
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Tutorial: Managing Memory Errors 1

3. Click the r000mi2 tab to redisplay the Sources window:

4. Click the Overview button to redisplay the Overview window:
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Recap

You edited the fi nd_and_fi x_nenory_errors. cpp source file to fix the Mismatched allocation/deallocation
problem.

Key Terms and Concepts

e Term: Observation
e Term: Problem
e Term: Problem set

e Term: Result

Resolve Next Issue

To resolve another detected memory error:

e Choose another problem set.

e Access more information on interpreting and resolving problems.
e Interpret the result data.

e Resolve the issue.

To choose another problem set:

In the Problems pane on the Overview window, double-click the data row for a Memory Leak problem set to
display the Sources window:
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To access more information on interpreting and resolving problems:

1. Right-click the Allocation site observation in the Code Locations in Problem(s) pane.
2. Choose Explain Problem to display Inspector Help information for the Memory Leak problem type.

To interpret result data:
A Memory leak problem occurs when a block of memory is allocated and never released.

The Allocation site observation represents the location from which the memory block was allocated. Here, the
source code shows a mal | oc() allocator.

Scroll the source code to near line 180:
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The issue is obvious: The free() call that releases the memory allocated by the mal | oc() call is commented
out.

To resolve memory leak problems (while avoiding related mismatched allocation/deallocation problems): Match
any mal | oc() call with afree() call, a newwith a del ete, and a new[] with a del ete[] as soon as all use of
the allocated space has occurred, but not sooner. Never mix and match. Be aware:

¢ If you do not deallocate soon enough, you waste space the program might need.
e If you deallocate too soon, you may do one of the following:

e Corrupt your memory allocator or the space it manages when you later write to that space.

e End up with bogus data if you later read that space when you previously returned it to the memory allocator.

e Make sure you free any space allocated within a function prior to exiting that function, or else make sure the
function caller does the deallocation for the called function.

To resolve the issue:

1. Click the find_and_fix_memory_errors.cpp tab to redisplay the fi nd_and_fi x_menory_errors. cpp
source file in the Visual Studio* editor:
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2. Uncomment //free(l ocal _nmbox); :

3. Click the r000mi2 tab to redisplay the Sources window:
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Recap
You:
1. Explored the memory leak problem detected in the fi nd_and_fi x_menory_errors. cpp source file.

2. Determined its cause: A mal | oc() call lacking a matching free() call.

3. Edited the source code to fix the problem.

Key Terms and Concepts

e Term: Observation
e Term: Problem
e Term: Problem set

e Term: Result

Rebuild and Rerun Analysis

To see if your edits resolved the memory errors:

e Rebuild the application with your edited source code.
e Run another analysis.
e Start managing result data after collection.

To rebuild the application:
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1. Right-click the find_and_fix_memory_errors project in the Solution Explorer.
2. Choose Build.

To run another analysis:
From the Visual Studio* menu, choose Tools > Intel Parallel Inspector 2011 > Re-inspect to run another
analysis of the same analysis type:

Notice the image now displays.
To start managing result data after collection:
Click the Interpret Result button to display the Overview window:
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Notice the Inspector :

¢ Created a new result tab.
¢ No longer detected Mismatched allocation/deallocation and Memory leak problems.

Try fixing the remaining problem set(s) yourself.

Recap
You:

1. Recompiled and linked the find_and_fix_memory_errors application, saving your edited source code.

2. Reinspected the fi nd_and_fi x_nmenory_errors. exe file to verify you successfully resolved previously
detected memory errors.

Key Terms and Concepts

e Term: Analysis

Summary

Here are some important things to remember when using the Inspector to manage memory errors:
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Step 1. Choose Project and Build Application.

Applications compiled/linked in debug mode using the following options produce the most accurate, complete
results: / Zi or/Zzl,/Cd, and / MD or / MDd.

You can control analysis cost without sacrificing completeness by using small, representative data sets. Data
sets with runs in the seconds time range are ideal. You can always create additional data sets to ensure all
your code is inspected.

Step 2. Collect Result.

Configure, then run an analysis:

The Inspector offers preset memory analysis configurations to help you control analysis scope and cost.
Widening analysis scope maximizes the load on the system, the time required to perform the analysis, and
the chances the analysis will fail because the system may run out of resources.

You can run memory error analyses from the Tools menu or toolbar. You can also use the i nsp-cl command.

Step 3. Manage Result.

Choose a problem set, interpret the result data, then resolve the issue:

An observation is a fact the Inspector observes at a source code location. A problem is a small group of closely
related observations (source code locations) that indicate an error in the target. A problem set is a larger
group of more loosely related observations (source code locations) that could share a common solution.

Think of the Problems pane on the Overview window as a to-do list: Start at the top and work your way
down.

Double-click an observation or problem set on the Overview window to navigate to the Sources window.
Click the Overview button on the Sources window to return to the Overview window.

Right-click an observation or problem set to display a pop-up menu, then choose Explain Problem to access
more information on interpreting and resolving the problem.

Double-click an observation on the Sources window to open the Visual Studio* editor.
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Tutorial: Managing Threading
Errors

Learning Objectives

This tutorial shows how to use the Intel® Parallel Inspector to identify, analyze, and resolve threading errors.

Estimated completion time: 10 - 15 minutes.

NOTE. This tutorial does not require prior completion of other tutorials. Consequently, some terms,
concepts, and workflow steps are common to all tutorials.

After you complete this tutorial, you should be able to:

e List, in order, the steps to manage threading errors.

e Define key Inspector terms, such as analysis, result, problem set, problem, and observation.
e Identify compiler/linker options that produce the most accurate, complete analysis results.

e Explain how data set size and workload impact application execution time and analysis speed.
e Run threading error analyses.

e Influence analysis scope and running time.

e Access help for the Inspector command-line interface.

¢ Navigate among windows in Inspector results.

e Display a prioritized to-do list for resolving errors.

e Access help for resolving specific errors.

e Access source code to fix errors.

Key Terms and Concepts

Key Terms
analysis: A process during which the Inspector performs collection and finalization.

collection: A process during which the Inspector executes an application, identifies issues that may need
handling, and collects those issues in a result.

false negative: The Inspector does not detect an error because the problem may be too complex/big or involve
too much runtime/memory cost.
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false positive: The Inspector detects something that is not an error.

finalization: A process during which the Inspector uses debug information from binary files to convert symbol
information into filenames and line numbers, perform duplicate elimination, and form problem sets.

observation: A fact the Inspector observes at a source code location, such as a write observation. A focus
observation is a source code location with relationships you choose to explore. A related observation is a source
code location with a relationship to a focus observation and possibly other observations.

problem: A small group of closely related observations (source code locations) that indicate an error in an
application, such as a data race problem.

problem set: A larger group of more loosely related observations (source code locations) that could share a
common solution, such as a problem set resulting from deallocating an object too early during program execution.
You can view problem sets only after analysis is complete.

project: A compiled application, collection of configurable attributes surrounding the compiled application, and
a container for results.

result: A collection of issues that may need handling.

target: An application you inspect for errors using the Inspector.

Key Concept: Choosing Small, Representative Data Sets

When you run a dynamic analysis, the Inspector executes an application against a data set. Data set size and
workload have a direct impact on application execution time and analysis speed.

For example, it takes longer to process a 1000x1000 pixel image than a 100x100 pixel image. A possible reason:
You may have loops with an iteration space of 1...1000 for the larger image, but only 1...100 for the smaller
image. The exact same code paths may be executed in both cases. The difference is the number of times these
code paths are repeated.

You can control analysis cost without sacrificing completeness by removing this kind of redundancy from your
data set.

Instead of choosing large, repetitive data sets, choose small, representative data sets that fully create threads
with minimal to moderate work per thread. Minimal to moderate means just enough work to demonstrate all the
different behaviors a thread can perform. Data sets with runs in the seconds time range are ideal. You can always
create additional data sets to ensure all your code is inspected.

Key Concept: Ensuring Applications Contain More Than One Thread

If you plan to run the Inspector on systems with only one processor, you may need to take special steps to
ensure applications create more than one thread:

Programming Possible Strategies
Model
Intel® Threading When initializing an object of class t bb: : t ask_schedul er _i ni t , use the following
Building Blocks function to force the creation of two or more threads: i nitialize (int), wherei nt
= 2 or higher.
For more information, see http://www.threadingbuildingblocks.org/
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Programming
Model

Possible Strategies

Windows* API
(Win32)

Use the following function to create as many threads as you need: Creat eThread -
Creates a thread to execute within the virtual address space of the calling process.

For more information, see http://msdn.microsoft.com/en-us/library/

OpenMP* API

Use the following to force the creation of two or more threads:

¢ OWP_NUM THREADS runtime environment variable - Sets the maximum number of
threads in the parallel region, unless overridden by an onp_set _num t hr eads

function or num t hr eads clause.

e onp_set_num t hr eads function - Sets the number of threads in subsequent parallel
regions, unless overridden by a num t hr eads clause.

e num t hr eads clause - Sets the number of threads in a thread team.

For more information, see http://msdn.microsoft.com/en-us/library/

Key Concept: Choosing Analysis Type Configurations

The Inspector offers preset memory and threading configurations to help you control analysis scope and cost.

Preset
Configurations

Advantages

Disadvantages

Narrowest scope

¢ Minimizes the load on the system.

¢ Minimizes the time required to perform
the analysis.

¢ Increases the chances the analysis will
complete successfully - particularly on
large applications/large data sets.

¢ Detects only simple errors.

e Provides no details.

Intermediate
scope(s)

e Detects important errors.

e Provides some context and detail for
detected errors.

¢ Increases the load on the system.

¢ Increases the time required to perform
the analysis.

¢ Increases the chances the analysis will
fail because the system may run out of
resources.

Widest scope

e Detects important errors.

e Provides context and maximum amount
of detail for detected errors.

¢« Maximizes the load on the system.

¢ Maximizes the time required to perform
the analysis.
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Preset Advantages Disadvantages
Configurations

¢ Maximizes the chances the analysis will
fail because the system may run out of
resources.

For more details, check the Inspector Help Index for configuration.

Workflow Steps to Identify, Analyze, and Resolve Threading
Errors

You can use the Inspector to identify, analyze, and resolve threading errors in parallel programs by performing
a series of steps in a workflow. This tutorial guides you through these workflow steps workflow steps using
tachyon_st udi o sample code.

|
NOTE. Click

for a video demonstration. Show Me Videos require Adobe* Flash* Player.

. Choose a project.

. Verify settings and build an application to inspect for errors.
. Configure a threading error analysis.

. Run the threading error analysis on the application.

. Choose a problem set in the analysis result.

. Choose a focus observation in the problem set.

N O U b WN R

. Interpret the result data.
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8. Resolve the issue.
9. Rebuild the application and rerun the threading error analysis.

Choose Project

To enable Inspector functionality:

e Open a Visual Studio* solution.

e Set a startup project.

To open a Visual Studio* solution:

1. From the Visual Studio* menu, choose File > Open > Project/Solution.

2. In the Open Project dialog box, open the t achyon_st udi o\ vc8\t achyon_Par al | el St udi o. sl n file to
display the tachyon_ParallelStudio solution in the Solution Explorer:

NOTE. See Prerequisites to locate and extract the *. sl n file.

To set a startup project:

1. Right-click the find_and_fix_threading_errors project.
2. Choose Set as Startup Project:
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Recap

You chose the find_and_fix_threading_errors project.

Key Terms and Concepts

e Concept: Choosing Small, Representative Data Sets

e Concept: Ensuring Applications Contain More Than One Thread

Build Application

You can use the Inspector on both debug and release modes of binaries containing native code; however, projects
compiled/linked in debug mode using the following options produce the most accurate, complete results.

Compiler/Linker Options Correct Setting Impact If Not Set Correctly

Debug information Enabled (/ Zi or/Zl) Missing file/line information

Optimization Disabled (/ Od) Incorrect file/line information

Dynamic runtime library Selected (/ MD or / M) False positives or missing
observations

To enable correct analysis of Intel® Threading Building Blocks (Intel® TBB) applications, you must also set the
following required macros before compiling:

e TBB_USE_DEBUG (which sets TBB_USE_THREADING_TOOLS) if you use Intel® TBB debug libraries
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e TBB_USE_THREADING_TOOLS if you use Intel® TBB release libraries
The impact if not set correctly: Intel Inspector XE may generate false positives. See Intel® TBB documentation
for more information.

To create an application the Inspector can inspect for threading errors:

e Verify debug mode is configured to produce the best results.
e Verify the application is set to build in debug mode.
e Build the application.

To verify debug mode is configured to produce the best resulits:

1. Right-click the find_and_fix_threading_errors project in the Solution Explorer.
2. Choose Properties to display the Property Pages dialog box.
3. Verify the Configuration drop-down list is set to Debug or Active(Debug).

4. In the left pane, choose Configuration Properties > C/C++ > General.

5. Verify the Debug Information Format is set to Program Database (/Zi) or Program Database for Edit
& Continue (/ZI).
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6. In the left pane, choose Configuration Properties > C/C++ > Optimization.
7. Verify the Optimization field is set to Disabled (/0d).

8. In the left pane, choose Configuration Properties > C/C++ > Code Generation.

9. Verify the Runtime Library field is set to Multi-threaded DLL (/MD) or Multi-threaded Debug DLL
(/MDd).
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10 In the left pane, choose Configuration Properties > Linker > Debugging.
11. Verify the Generate Debug Info field is set to Yes (/DEBUG).

To verify the application is set to build in debug mode:

1. Click the Configuration Manager button.

53



2 Intel® Parallel Inspector 2011 Getting Started Tutorials

2. Verify the Active solution configuration drop-down list is set to Debug.

3. Click the Close button to close the Configuration Manager dialog box.
4. Click the OK button to close the Property Pages dialog box.
To build the application:

1. From the Visual Studio* menu, choose Debug > Start Without Debugging.
2. If the Visual Studio* IDE responds any projects are out of date, click Yes to build.
3. Check for a display similar to the following:

Notice the white dots in the the image. The cause: Threading errors.

54



Tutorial: Managing Threading Errors 2

Recap

You verified the find_and_fix_threading_errors project is set to produce the most accurate, complete results;
compiled and linked the application; and ensured the resulting fi nd_and_fi x_t hreadi ng_errors. exe file
runs on your system outside the Inspector.

Key Terms and Concepts

e Term: False negative

e Term: False positive

Configure Analysis

Choose a preset configuration to influence threading error analysis scope and running time.
To configure a threading error analysis:

1. From the Visual Studio* menu, choose Tools > Intel Parallel Inspector 2011 > Inspect Threading
Errors to display the Configure Analysis dialog box:
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The Analysis type drop-down list shows Inspector dynamic analysis type offerings: Memory
error analysis and threading error analysis.

This tutorial covers threading error analyses, which you can use to search for these kinds of
errors: Data race, deadlock, lock hierarchy violation, and cross-stack thread access.

Use memory error analyses to search for these kinds of errors: GDI resource leak, kernel resource
leak, invalid memory access, memory leak, mismatched allocation/deallocation, missing allocation,
and uninitialized memory access.

The Analysis Time Overhead gauge shows the time it may take to collect a result at each
preset configuration. Time is expressed in relation to normal application execution time. For
example, 2x - 20x is 2 to 20 times longer than normal application execution time. If normal
application execution time is 5 seconds, estimated collection time is 10 to 100 seconds.

Here, the configuration slider rests at the Does my target have deadlocks? preset
configuration, which has the narrowest scope/lowest overhead. Try dragging the configuration
slider to see the impact on the gauge.

The configuration details region shows current configuration characteristics. Try dragging the
configuration slider to see the impact on the details region.

Suppressing known issues can dramatically improve your productivity. For more details, check
the Inspector Help Index for suppression rule.
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2. Drag the configuration slider to the Does my target have deadlocks or data races? preset configuration:

Recap

You chose a preset configuration of intermediate scope to detect threading errors in the
find_and_fix_menory_errors. exe file.

Key Terms and Concepts

e Term: Analysis
e Term: Target

e Concept: Choosing Analysis Type Configurations

Run Analysis

Run a threading error analysis to detect threading errors that may need handling.
To run a threading error analysis:

Click the Run Analysis button on the Configure Analysis dialog box to:
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e Execute the find_and_fix_threadi ng_errors. exe file.

o Identify threading errors that may need handling.

e Collect the result in a folder in the t achyon_st udi o\ vc8\ I nspect or\ My | nspector Results folder.

¢ Finalize the result (convert symbol information into filenames and line numbers, perform duplicate elimination,
and form problem sets).

During collection, the Inspector displays a Collection Log window similar to the following:

The Visual Studio* IDE offers a pointer to the result from the Solution Explorer to provide easy
future access. Here, the Visual Studio* IDE created a find_and_fix_threading_errors\My
Inspector Results folder in the Solution Explorer with a pointer to the r000ti2 result.

The result name appears in the tab. Here, the name of the result (and the name of the result folder
in the t achyon_st udi o\ vc8\ I nspector\ My | nspector Results folder) is r000ti 2, where:

e r = constant
e 000 = next available number
e ti = threading error analysis type

e 2 = preset configuration of intermediate scope

The Collection Log pane shows detected problems in real time.

This tutorial does not cover examining and solving problems during collection. For more details,
check the Inspector Help Index for examine result during analysis.
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The Visual Studio* Output window shows Inspector analysis status messages.

If necessary, choose Intel Parallel Inspector messages in the Show output from drop-down
list to see the status messages.

The Interpret Result button displays after analysis (both collection and finalization) completes
successfully.

You can examine and solve problems during collection - and continue to examine and solve problems
after collection and finalization are complete - but there are trade-offs involved.

ﬂ TIP. Wait until analysis is complete, then click the Interpret Result button to use the
full range of Inspector capabilities to manage result data in a more efficient, effective,
and productive manner.

NOTE. This tutorial explains how to run an analysis from the Inspector graphical user interface
(GUI). You can also use the Inspector command-line interface (i nsp-cl command) to run an
analysis. For more details, check the Inspector Help Index for insp-c/ command.

To start managing result data after analysis is complete:
Click the Interpret Result button to display the Overview window:

Recap

You inspected the fi nd_and_fi x_t hreadi ng_errors. exe application for threading errors, during which:
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The Inspector ran the fi nd_and_fi x_t hreadi ng_err ors. exe file, identified threading errors that may need
handling, collected a result in the t achyon_st udi o\ vc8\ I nspect or\ My | nspector Resul ts\r000ti 2
folder, converted symbol information into filenames and line numbers, performed duplicate elimination, and
formed problem sets.

The Visual Studio* IDE added a pointer to the r 000t i 2 result from the Solution Explorer.

Key Terms and Concepts

Term:
Term:
Term:
Term:

Term:

Analysis
Collection
Finalization
Problem Set

Result

Choose Problem Set and Focus Observation

To start exploring a detected threading error:

Interpret the window.

Choose a problem set.

Choose a focus observation.

To interpret the Overview window:
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The Overview window is the default starting point for managing result data. It groups observations
into problem sets, and then prioritizes the problem sets by severity and size.

The Details window is the advanced starting point for managing result data - it does not group
observations into problem sets. This tutorial does not cover searching for observations that answer
specific questions only you can formulate. For more details, check the Inspector Help Index for
select/observation search criteria.

The arrows in the Navigation toolbar indicate you can access the Sources window from both the
Overview and Details windows.

Think of the Problems pane as a to-do list. Start at the top and work your way down.

The Code Locations in Problem(s) pane shows all the observations in all the problems in the
selected problem set. By default, the Inspector selects the first problem set for you.

Here, the Inspector selected a Data race problem set, which contains one or more problems
composed of several Read and Write observations in the wi nvi deo. h source file.

The Filters pane (toggled off by default) categorizes all displayed problem sets by specific criteria.
Use it to temporarily limit the list in the Problems pane to only those problem sets that meet
specific criteria.

This tutorial does not cover searching for specific problem sets. For more details, check the Inspector
Help Index for select/problem set search criteria.

To choose a problem set:

Click the data row for the Data race problem set in the fi nd_and_fi x_t hreadi ng_errors. cpp source file to
display a window similar to the following:
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This Data race problem set contains one or more problems composed of Read and Write observations.
To choose a focus observation:

Double-click the data row for the X6 Write observation to display the Sources window, which provides more
visibility into the error:

Recap

You started exploring a Data race problem set that contains one or more problems composed of Read and
Write observations.

Key Terms and Concepts

e Term: Focus observation
e Term: Observation

e Term: Problem

e Term: Problem set

e Term: Result

Interpret Result Data

To determine the cause of the detected threading error:

e Interpret the window.
e Interpret window icons.
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View source code for another observation.
Understand the issue.

Access more information on interpreting and resolving problems.

To interpret the Sources window:

Like the pane on the Overview window, the Code Locations in Problem(s) pane shows all the
observations in one Write -> Write Data race problem and one Write -> Read Data race problem
in the Data race problem set.

The Write -> Write Data race problem contains two observations:

e The X6 Write observation represents the instruction and associated call stack of the thread
responsible for a memory write.

¢ The X7 Write observation represents the instruction and associated call stack of the thread
responsible for a concurrent memory write.

The Write -> Read Data race problem also contains two observations:

e The X6 Write observation represents the instruction and associated call stack of the thread
responsible for a memory write.

e The X8 Read observation represents the instruction and associated call stack of the thread
responsible for a concurrent memory read.

Notice the X6 Write observation is in both problems.
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The Relationships pane shows the relationship between the two Write observations in the Write
-> Write Data race problem. In relationship diagrams:

e Each box in a diagram represents an observation in one problem in a problem set.
e A diagram with a single box is a trivial problem with no related observation.

e Vertically stacked boxes indicate concurrent observations. Here, the two Write observations
occur concurrently.

¢ Boxes arranged left-to-right with connecting arrows indicate a time ordering.
e Boxes with connecting lines indicate association.

The Related Code Location pane shows the source code in the

find_and_fix_threadi ng_errors. cpp source file surrounding the X7 Write observation. (Notice
the B icon in the pane title matches the B icon on the X7 Write observation data row in the Code
Locations in Problem(s) pane.) The source code corresponding to the Write observation is
highlighted.

The Focus Code Location pane shows the source code in the

find_and_fix_threadi ng_errors. cpp source file surrounding the X6 Write observation. (Notice
the ® icon in the pane title matches the P icon on the X6 Write observation data row in the Code
Locations in Problem(s) pane.) The source code corresponding to the Write observation is
highlighted.

To interpret window icons:

Icon Meaning

E) This observation is the focus observation. You chose it when you | Observation source code is
double-clicked the X6 Write observation on the Overview available for viewing in the
window. Its source code is currently displayed in the Focus Code | Inspector and editing in the
Location pane. Visual Studio* code editor.

El This observation is related to the focus observation. Its source

code is currently displayed in the Related Code Location pane.

This is another observation in the problem or problem set. Its
source code is not currently displayed onscreen.

To view source code for another observation:

Double-click the data row for the Read observation in the Code Locations in Problem(s) pane to display a
window similar to the following:
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Notice the window changes:

* The Relationships pane now shows the relationship between the Write and Read observations in the Write
-> Read Data race problem.

e The Related Code Location pane now shows the source code for the Read observation.

¢ The icon for the Read observation is now B instead of E in the Code Locations in Problem(s) pane (and
throughout the Sources window).

To understand the issue:

A Write -> Write Data race problem occurs when multiple threads write to the same memory location without
proper synchronization. A Write -> Read Data race problem occurs when one thread writes to, while a different
thread concurrently reads from, the same memory location.

The commenting in the Focus Code Location window identifies the cause of the Data race problems: Multiple
threads are concurrently accessing the global variable col . One possible correction strategy: Change the global
variable to a local variable.

To access more information on interpreting and resolving problems:

1. Right-click any observation in the Code Locations in Problem(s) pane or box in the Relationships pane.
2. Choose Explain Problem to display Inspector Help information for the Data race problem type.

Recap

You determined the cause of a Data race problem set in the fi nd_and_fi x_t hreadi ng_errors. cpp source
file: Multiple threads are concurrently accessing the global variable col .
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Key Terms and Concepts

e Term: Focus observation
e Term: Observation

e Term: Problem

e Term: Problem set

e Term: Related observation

e Term: Result

Resolve Issue

Access the Visual Studio* editor to fix the threading error.
To resolve the issue:
1. Scroll to this source code near line 80 in the Focus Code Location pane: col or col;

2. Double-click the line to open the fi nd_and_fi x_t hreadi ng_errors. cpp source file in a separate tab where
you can edit it with the Visual Studio* editor:

3. Comment col or col; and uncomment//col or col; near line 89:
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4. Click the r000ti2 tab to redisplay the Sources window:
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Recap

You edited the fi nd_and_fi x_t hreadi ng_errors. cpp source file to fix the problems in the Data race problem
set.

Key Terms and Concepts

e Term: Observation
e Term: Problem
e Term: Problem set

e Term: Result

Rebuild and Rerun Analysis

To see if your edits resolved the threading errors:

e Rebuild the application with your edited source code.
e Run another analysis.

e Start managing result data after collection.

To rebuild the application:
1. Right-click the find_and_fix_threading_errors project in the Solution Explorer.

2. Choose Build.

To run another analysis:

From the Visual Studio* menu, choose Tools > Intel Parallel Inspector 2011 > Re-inspect to run another
analysis of the same analysis type:
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To start managing result data after collection:

Click the Interpret Result button to display the Overview window:

Notice the Inspector :

e Created a new result tab.
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¢ No longer detects problems in the fi nd_and_fi x_t hreadi ng_errors. cpp file.

Recap
You:

1. Recompiled and linked the find_and_fix_threading_errors application, saving your edited source code.

2. Reinspected the fi nd_and_fi x_t hreadi ng_errors. exe file to verify you successfully resolved previously
detected threading errors.

Key Terms and Concepts

e Term: Analysis

Summary

Here are some important things to remember when using the Inspector to manage threading errors:

Step 1. Choose Project and Build Application.
e Applications compiled/linked in debug mode using the following options produce the most accurate, complete
results: / Zi or/Zzl,/Qd, and / MD or / Md.

e You can control analysis cost without sacrificing completeness by using small, representative data sets. Data
sets with runs in the seconds time range are ideal. You can always create additional data sets to ensure all
your code is inspected.

Step 2. Collect Result.
Configure, then run an analysis:

¢ The Inspector offers preset threading analysis configurations to help you control analysis scope and cost.
Widening analysis scope maximizes the load on the system, the time required to perform the analysis, and
the chances the analysis will fail because the system may run out of resources.

e You can run threading error analyses from the Tools menu or toolbar. You can also use the i nsp-cl command.

Step 3. Manage Result.
Choose a problem set, interpret the result data, then resolve the issue:

e An observation is a fact the Inspector observes at a source code location. A problem is a small group of closely
related observations (source code locations) that indicate an error in the target. A problem set is a larger
group of more loosely related observations (source code locations) that could share a common solution.

e Think of the Problems pane on the Overview window as a to-do list: Start at the top and work your way
down.

e Double-click an observation or problem set on the Overview window to navigate to the Sources window.
Click the Overview button on the Sources window to return to the Overview window.
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e Right-click an observation or problem set to display a pop-up menu, then choose Explain Problem to access
more information on interpreting and resolving the problem.

e Double-click an observation on the Sources window to open the Visual Studio* editor.
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More Resources

Getting Help

Browsing Help in the Microsoft Document Explorer
You can browse and search for topics in different ways:

e Use Help > Contents to open the Contents window and browse the Table of Contents.

e To view help for an installed parallel studio tool, select Help > Intel Parallel Studio 2011 > Parallel Studio
Help and select the tool icon to open the title page of that tool.

e Use Help > Index to open the Index window and access an index to topics. Either type in the keyword you
are looking for, or scroll through the list of keywords.

e Use Help > Search to open the Search page and search the full text of topics in the help.

Locating Intel Topics

To filter the documentation so that only the Intel documentation appears, select Help > Contents from the
Visual Studio* user interface. In the Filtered by: drop-down list, select Intel.

To determine where the currently displayed topic appears in the table of contents (TOC), click the '15-] Sync
with Table of Contents button on the Visual Studio toolbar to highlight the topic in the Contents pane.

Where applicable, the Parallel Studio help topics provide a Where am I in the workflow? button. Click
the button to view the workflow with a highlight on the stage that this topic discusses.

Activating Intel Search Filters

With Microsoft Visual Studio 2005 and 2008, you can include Intel documentation in all search results by checking
the Intel search filter box for the Language, Technology, and Content Type categories. You must check the
Intel search box for all three categories to include Intel documentation in your searches. Unchecking all three
Intel search boxes excludes Intel documentation from search results. The Intel search filters work in combination
with other search options for each category.
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Using Context-Sensitive Help

Context-sensitive help enables easy access to help topics on active GUI elements. The following context-sensitive
help features are available on a product-specific basis:

e ? Help: Click the ? button, in the upper-right corner of the dialog box or pane to get help for the dialog box
or pane.

e F1 Help: Press F1 to get help for an active dialog box, property page, pane, window, or for the currently
selected function in the code editor.

e Dynamic Help: Select Help > Dynamic Help to open the Dynamic Help window, which displays links to
relevant help topics for the current window, or for the currently selected functions in the code editor.

Product Website and Support

The following links provide information and support on Intel software products, including Intel® Parallel Studio:
e http://www.intel.com/software/products/
At this site, you will find comprehensive product information, including:

e Links to each product, where you will find technical information such as white papers and articles
e Links to user forums
e Links to news and events

e http://software.intel.com/en-us/articles/intel-parallel-studio/

Intel® Software Network, Parallel Studio Support page, with links to support forums, startup help, knowledge
base, and getting started video.

e http://software.intel.com/en-us/articles/tools/
Intel® Software Development Products Knowledge Base.
e http://www.intel.com/software/products/support/

Technical support information, to register your product, or to contact Intel.

For additional support information, see the Technical Support section of your Release Notes.

System Requirements

For detailed information on system requirements, see the Release Notes.
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