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Introducing the Intel® Parallel
Amplifier

The Intel® Parallel Amplifier, an Intel® Parallel Studio tool, provides information on the performance of
your code.

Use the Amplifier to analyze the following types of performance issues in your applications:

e Identify the most time-consuming (hot) functions in your application

e Locate sections of code that do not effectively utilize available processor time

e Determine the best sections of code to optimize for sequential performance and for threaded performance
e Locate synchronization objects that affect the application performance

e Find whether, where, and why your application spends time on input/output operations

e Identify and compare the performance impact of different synchronization methods, different numbers
of threads, or different algorithms

Intel Parallel Amplifier Tutorials

These tutorials tell you how to use the Amplifier to analyze the performance of a sample application on a
multi-core system, determine if all cores are fully utilized when the application is running, and identify
sections of code that can benefit from threading.

e Finding Hotspots
e Identifying Concurrency

e Analyzing Locks and Waits

Check http://software.intel.com/en-us/articles/intel-software-product-tutorials/ for the following:

e Printable version (PDF) of all Amplifier tutorials
e ShowMe videos of each Amplifier tutorial
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Prerequisites

You need the following tools, skills, and knowledge to effectively use these tutorials.

D NOTE. The instructions and screen shots in these tutorials refer to the Visual Studio* 2005
integrated development environment (IDE). However, you can use these instructions for later
versions of the Visual Studio* IDE.

Required Tools

You need the following tools to use these tutorials:

e Intel® Parallel Amplifier

e Sample code shipped with the Amplifier

o Amplifier Help

To install the Amplifier, follow the instructions in the Release Notes.
To install and set up Amplifier sample code:

1. Copy the t achyon_st udi o. zi p file from the Sanpl es\ <l ocal e> folder in the Intel® Parallel Studio
installation folder (the default installation folder is C:\ Program Fil es\Intel\Parall el Studio
2011) to a writable directory or share on your system.

2. Extract the sample(s) from the . zi p file.

D NOTE.

e Samples are non-deterministic. Your screens may vary from the screen shots shown
throughout these tutorials.

e Samples are designed only to illustrate Amplifier features and do not represent best
practices for tuning the code. Results may vary depending on the nature of the analysis.

To access Amplifier Help:
See the Getting Help topic.

Required Skills and Knowledge

These tutorials are designed for developers with the following skills and knowledge:
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Basic understanding of the Microsoft Visual Studio* 2005 development environment (IDE), including
how to:

e Open a project/solution.

¢ Display the Solution Explorer and Output windows.
e Compile and link a project.

e Ensure a project compiled successfully.

¢ Access the Document Explorer window.
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Navigation Quick Start

Intel® Parallel Amplifier/Microsoft Visual Studio* 2005 Integration

The Amplifier integrates into the Visual Studio* development environment (IDE) and can be accessed
from the menus, toolbar, and Solution Explorer in the following manner:

tachyon_studio - Microsoft Visual Studio

File Edit View Project Build Debug Tools Window Community Help
- - o bl | 6 Ga G -0 BB B Release - ';' i T [d 5 Cd fad (3 4 b s
= A = =
Profile Concurrency - Where s = il # b Compare H1N S
]
Solution Explarer * 3 X v000cc! find_hotspots.cpp - X gSummarv > 1 x
- Concurrency c lel E':Ss;:;—fm: ;g'g;?s
[ Solution 'tachyon_studio' (3 proj (I e | '
k & Top-down Tree Wait Time: 162.167s
Bl G Amplifier D Wait Count: 2851
= 4 find_hotspots 1 = doun.
2 [ My Amplifier Results || | Fonction CPU Time by Utiiization:Self = x s ng;ioﬁ:f Time: 83, 38?52
- Caller Function Ti '
r000ce.ampl o A s Dide @ Poor Ok M Ideal @ Over Threads Created: 3
LD EERE Y = initaize_2D buffer tachyon_firfi8
n] find_hotspots.h rid_intersect 17,512 [N tachyon_fin
33 identify_concurrency [ sphere_intersect 10,5555 [N tachyon_fin
Composer [Hgrid_bounds_intersect 1.502s @ tachyon_fin
Inspector B [#Hpos2grid 0.473s 1 tachyon_fin
tachyon.common [#shader 0.421s1 tachyon_fin 2
[Htri_intersect 0,150z | tachyon_fin E
video:inext_frame 0.554s tachyon_fin
Selected: 27.993s b
< | RAlIES | Ed Simultan
¥ |Filter: 100% is shown I'~'10du|e:|[AII] v|Thread:|[AII] v| ¥ = B summary tack (G
E -
Output + 1% Dynamic Help >~ 1 X
Show output from:  Intel Parallel Amplifier 2011 messages = | 5l | & 2 | =g | [F] @ How Dol Q search & Index i
Finalizing the result toock €1.74% seconds 'Ill Help
H Tab: Concurrency Result I
< | @) [ Error List |[=] Output #Properties | [@]Dynamic Help
Ready
A Use the Amplifier toolbar to configure and control result collection.
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Amplifier results *. anpl show up in the Solution Explorer under the My Amplifier

B
Results folder. To configure and control result collection, right-click the project in the
Solution Explorer and select the Intel Parallel Amplifier 2011 menu from the pop-up
menu. To manage previously collected results, right-click the result (for example,
r 000cc. anpl ) and select the required command from the pop-up menu.

c Use the Amplifier result tabs to manage result data.

D Click buttons on navigation toolbars to change window views and toggle window panes
on and off.

E Use the filter toolbar to filter out the result data according to the selected categories.

F Click & icons to display help snippets that briefly describe window purpose and provide
links to more help information. (You can also press the F1 key to display help pages
that more completely describe window purpose.)

G Use the Summary and Call Stack tabs to view basic metrics on the overall application
performance and call paths for a function selected in the result tab.

H Use the Output window to view target execution and analysis output.

In Microsoft Visual Studio* 2005/2008, use the Dynamic Help window to access help
topics related to the current Amplifier window.

12




Key Terms and Concepts

Key Terms

baseline: A performance metric used as a basis for comparison of the application versions before and
after optimization. Baseline should be measurable and reproducible.

CPU time: The amount of time a thread spends executing on a logical processor. For multiple threads,
the CPU time of the threads is summed. The application CPU time is the sum of the CPU time of all the
threads that run the application.

Elapsed time:The total time your target ran, calculated as follows: Wall clock time at end of application
- Wall clock time at start of application.

hotspot: A section of code that took a long time to execute. Some hotspots may indicate bottlenecks
and can be removed, while other hotspots inevitably take a long time to execute due to their nature.

target: A target is an executable file you analyze using the Intel® Parallel Amplifier.

Wait time: The amount of time that a given thread waited for some event to occur, such as:
synchronization waits and I/0 waits.

Key Concept: Concurrency Analysis

The Concurrency analysis helps identify hotspot functions where processor utilization is poor. When cores
are idle at a hotspot, you have an opportunity to improve performance by getting those cores working
for you.

The Concurrency analysis provides information on how many threads were running at each moment during
application execution. It includes threads which are currently running or ready to run and therefore are
not waiting at a defined waiting or blocking API. The Amplifier also shows CPU time while the hotspot was
executing. A red bar indicates time where the processors are poorly utilized giving you exactly the
information you need to decide where you should tune.

Key Concept: CPU Utilization

For the Concurrency and the Locks and Waits analyses, the Intel® Parallel Amplifier identifies a processor
utilization scale, calculates the target concurrency, and defines default utilization ranges depending on
the number of processor cores. You can change the utilization ranges by dragging the slider in the Summary
tab.

13
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Utilization Default Description
Type color

Idle

All threads in the program are waiting - no threads are running. There can
be only one node in the Summary tab graph indicating idle utilization.

Poor [ Poor utilization. By default, poor utilization is when the number of threads
is up to 50% of the target concurrency.

OK — Acceptable (OK) utilization. By default, OK utilization is when the number
of threads is between 51-85% of the target concurrency.

Ideal 2] Ideal utilization. By default, ideal utilization is when the number of threads
is between 86-115% of the target concurrency.

Over [ Over-utilization. By default, over-utilization is when the number of threads
is more than 115% of the target concurrency.

Key Concept: Data of Interest

The Amplifier maintains a special column called Data of Interest. This column is highlighted with
yellow background and a yellow star in the column header .

The data in the Data of Interest column is used by various windows as follows:

e The Call Stack tab calculates the contribution, shown in the contribution bar, using the Data of
Interest column values.

e The Filter bar uses the data of interest values to calculate the percentage indicated in the filtered
option.

e The Source/Assembly window uses this column for hotspot navigation.

If a view has more than one column with numeric data or bars, you can change the default Data of
Interest column by right-clicking the required column and selecting the Set Column as Data of
Interest command from the pop-up menu.

Key Concept: Finalization

Finalization is a process when the Amplifier converts the collected data to a database, resolves
symbol information, and pre-computes data to make further analysis more efficient and responsive.
The Amplifier finalizes data automatically when generating results.

14



Key Terms and Concepts

You may want to re-finalize a result to:

e update symbol information after changes in the search directories settings

e resolve the number of [Unknown]-s in the results

Key Concept: Hotspots Analysis

The Hotspots analysis helps understand the application flow and identify sections of code that took
a long time to execute (hotspots). A large number of samples collected at a specific process, thread,
or module can imply high processor utilization and potential performance bottlenecks. Some hotspots
can be removed, while other hotspots are fundamental to the application functionality and cannot
be removed.

The Intel® Parallel Amplifier creates a list of functions in your application ordered by the amount of
time spent in a function. It also detects the call stacks for each of these functions so you can see
how the hot functions are called.

The Amplifier uses a low overhead (about 5%) statistical sampling algorithm that gets you the
information you need without a significant slowing of application execution.

Key Concept: Locks and Waits Analysis

While the Concurrency analysis helps identify where your application is not parallel, the Locks and

Waits analysis helps identify the cause of the ineffective processor utilization. One of the most common
problems is threads waiting too long on synchronization objects (locks). Performance suffers when
waits occur while cores are under-utilized.

During the Locks and Waits analysis you can estimate the impact each synchronization object
introduces to the application and understand how long the application was required to wait on each
synchronization object, or in blocking APIs, such as sleep and blocking I/0.

15
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Intel® Parallel Amplifier
Tutorial: Finding Hotspots

Learning Objectives

This tutorial shows how to use the Hotspots analysis of the Intel® Parallel Amplifier to understand where
the sample application is spending time, identify hotspots - the most time-consuming program units, and
detect how they were called. Some hotspots may indicate bottlenecks that can be removed, while other
hotspots are inevitable and take a long time to execute due to their nature. Typically, the hotspot functions
identified during the Hotspots analysis use the most time-consuming algorithms and are good candidates
for parallelization.

The Hotspots analysis is useful to analyze the performance of both serial and parallel applications.
Estimated completion time: 15 minutes.

After you complete this tutorial, you should be able to:

e Choose an analysis target.

e Choose the Hotspots analysis type.

e Run the Hotspots analysis to locate most time-consuming functions in an application.
¢ Analyze the function call flow and threads.

e Analyze the source code to locate the most time-critical code lines.

e Compare results before and after optimization.

Workflow Steps to Identify and Analyze Hotspots

You can use the Intel® Parallel Amplifier to identify and analyze hotspot functions in your serial or parallel
application by performing a series of steps in a workflow. This tutorial guides you through these workflow
steps while using a sample ray-tracer application named t achyon.

D NOTE. Click for a video demonstration. Show Me videos require Adobe* Flash*
Player.

17
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Choose target

Build target

Run Hotspots
analysis

Interpret results

Interpret results _.._[DCDITID-EII'E mthg)

revious result

View source

Tune algorithms

1. Choose a target to analyze for hotspots.

2. Configure environment and project settings and build your target.

3. Choose and run the Hotspots analysis.

4. Interpret the result data.

5. View and analyze code of the performance-critical function.

6. Modify the code to tune the algorithms or rebuild the code with Intel® Compiler.

7. Re-build the target, re-run the Hotspots analysis, and compare the result data before and after
optimization.

18
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Choose Target

Before you start you need to choose the target in the Microsoft Visual Studio* environment. For this
tutorial, your target is a ray-tracer application, t achyon. To learn how to install and set up the
sample code, see Prerequisites.

D NOTE. The steps below are provided for Microsoft Visual Studio 2005. They may slightly
differ for other versions of Visual Studio.

To choose a target:
1. From the Visual Studio menu, select File > Open > Project/Solution....

The Open Project dialog box opens.

2. In the Open Project dialog box, browse to the location you used to unzip the
t achyon_st udi o. zi p file and select the t achyon_Par al | el St udi o. sl n file.

-

#¢ tachyon_ParallelStudio - Microsoft Visual St

File Edit Wew Project Build Debug Tools W
RSERA= A= - A -

Proﬁle Concurrency - Whereism ~ B 01 3%
1| Solution Explorer - Amplifier > 0 X

2 4
_j Solution 'tachyon_ParallelStudio’ {10 projects)
= i Amplifier
33 analyze_locks
33 find_hotspots
33 identify_concurrency

xoquon | S | Jauojd: 3 demas
[

R

35 tachyon.commaon

The solution is added to Visual Studio IDE and shows up in the Solution Explorer.

3. In the Solution Explorer, right-click the find_hotspots project and select Project > Set as
StartUp Project.

find_hotspots appears in bold in the Solution Explorer.

19
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Recap

You selected the find_hotspots project as the target for the Hotspots analysis.

Key Terms and Concepts

e Term: target

e Concept: Hotspots Analysis

Build Target

After choosing the analysis target, do the following to ensure the Intel® Parallel Amplifier provides
the most accurate information on the performance of your application:

e Build the target in the release mode with full optimizations, which is recommended for performance
analysis.
e Run the application without debugging to create a performance baseline.

e Configure the Microsoft Visual Studio* environment to download the debug information for system
libraries so that Amplifier can properly identify system functions and classify and attribute functions.

e Configure Visual Studio project properties to generate the debug information for your application
so that Amplifier can open the source code.

D NOTE. The steps below are provided for Microsoft Visual Studio 2005. They may slightly
differ for other versions of Visual Studio.

Choose a Build Mode and Build a Target

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your
target project.

2. From the Visual Studio menu, select Build > Build find_hotspots.

The t achyon_fi nd_hot spot s. exe application is built.

Create a Performance Baseline

1. From the Visual Studio menu, select Debug > Start Without Debugging.

The t achyon_fi nd_hot spot s application starts running.

20



Intel® Parallel Amplifier Tutorial: Finding Hotspots 1

u NOTE. Before you start the application, minimize the amount of other software running
on your computer to get more accurate results.

M tachyon_find_hotspots.exe CPU Time: 64.687 seconds.

2. Note the execution time displayed in the window caption. For the t achyon_fi nd_hot spot s
executable in the figure above, the execution time is 64.687 seconds. The total execution time
is the baseline against which you will compare subsequent runs of the application.

21
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D NOTE. Run the application several times, note the execution time for each run, and use
the average number. This helps to minimize skewed results due to transient system
activity.

Enable Downloading the Debug Information for System Libraries

1. Go to Tools > Options....
The Options dialog box opens.
2. From the left pane, select Debugging > Symbols.

3.
In the Symbol file (.pdb) locations field, click the button and specify the following address:
http://msdl.microsoft.com/download/symbols.

4. Make sure the added address is checked.

5. In the Cache symbols from symbol servers to this directory field, specify a directory where
the downloaded symbol files will be stored.

6. For Microsoft Visual Studio* 2005, check the Load symbols using the updated settings when
this dialog is closed box.

22
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7. Click OK.

Enable Generating Debug Information for Your Binary Files

1. Select the find_hotspots project and go to Project > Properties.

2. From the find_hotspots Property Pages dialog box, select Configuration Properties >
General and make sure the selected Configuration (top of the dialog) is Active(Release).

3. From the find_hotspots Property Pages dialog box, select C/C++ > General pane and specify
the Debug Information Format as Program Database (/Zi).

find_hotspots Property Pages

Configuration: |Active(ReIease}

| Platform: | Active(Win32Z)

V| [ Configuration Manager... l

Commaon Properties
[=)- Configuration Properties
General
Debugging
= CfC++

Optimization
Preprocessor
Code Generation
Language
Precompiled Headers
Qutput Files
Browse Information
Advanced
Command Line
Linker
Manifest Tool
¥ML Document Generator
Browse Information
Build Events
Custom Build Step
Web Deployment

- BB B -

Additional Indude Directories
Resolve 2using References
Debug Information Format
Suppress Startup Banner
Warning Level

Detect 64-bit Portability Issues
Treat Warnings As Errors

Use UNICODE Response Files

Additional Include Directories

L\SFC

Program Database (/Zi)
ves (fnologo)

Level 3 (fW3)

Yes (/Wped)

Mo

fes

Specifies one or more directories to add to the include path; use semi-colon delimited list if more than one.

(/I[path])

I OK H Cancel ]

4. From the find_hotspots Property Pages dialog box, select Linker > Debugging and set the

Generate Debug Info option to Yes (/DEBUG).

23
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find_hotspots Property Pages

Configuration: |-"\CﬁVE(RE|EBSE} w | Platform: |Active(Win32) v | [ Configuration Manager... l
Comman Properties Generate Debug Info Yes (/DEBUG)
- Configuration Properties Generate Program Database File &(TargetDir) ${TargetMame). pdb
General Strip Private Symbols
ngugging Generate Map File Mo
CfC++ Map File Name
= Linker Map Exports Mo
f':pnuiral Debugaable Assembly MNo Debuggable attribute emitted
Manifest File
System
Optimization
Embedded IDL
Advanced
Command Line
Manifest Tool
¥ML Document Generator
Browse Information
Build Events
Custom Build Step
Web Deployment
Generate Debug Info
Enables generation of debug information.  (f/DEBUG)
I QK l [ Cancel

Recap

You chose the target for the Hotspots analysis, set up your environment to enable generating symbol
information for system libraries and your binary files, built the target in the Release mode, and
created the performance baseline. Your application is ready for analysis.

Key Terms and Concepts

e Term: target, baseline

24
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Run Hotspots Analysis

After building the application, you can run it to analyze its performance. In this tutorial, you run the
Hotspots analysis to identify the hotspots that took much time to execute.

To run an analysis:

1. From the Amplifier toolbar, select Hotspots — Where is my program spending time running?

E Profile [Locks and Waits - Where [=| B 01 3 g Comp:
Hotspots - Where is my program ding time?
£ | Concurrency - Where is my concurrency poor?

(Global Scope)  |Locks and Waits - Where is my program waiting?

Mew result [

2. Click the Profile button.

Amplifier launches the t achyon_f i nd_hot spot s application that renders bal | s. dat as an input
file, calculates the execution time, and exits. Amplifier finalizes the collected results and opens the
Hotspots result tab.

ﬂ NOTE. To make sure the performance of the application is repeatable, go through the
entire tuning process on the same system with a minimal amount of other software
executing.
Recap

You launched the Hotspots data collection that analyzes function calls and CPU time spent in each
program unit of your application.

ﬂ NOTE. This tutorial explains how to run an analysis from the Amplifier graphical user
interface (GUI). You can also use the Amplifier command-line interface (anpl - cl
command) to run an analysis. For more details, check the Command-line Interface
Support section of the Amplifier Help.

Key Terms and Concepts

e Term: hotspot, Elapsed time

e Concept: Hotspot Analysis, Finalization

25
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Interpret Result Data

When the sample application exits, the Bottom-up window displays functions ordered bottom up: a
child function is placed directly above its parent. To interpret the data on the sample code performance,
do the following:

e Understand the basic performance metrics provided by the Hotspots analysis.
e Analyze the most time-consuming functions.

D NOTE. The screen shots and execution time data provided in this tutorial are created
on a system with two CPU cores. Your data may vary depending on the number and type
of CPU cores on your system.

Understand the Basic Hotspots Metrics

~r000hs ~ x || Call stack > 1 x
Hotspots

@& Top-down Tree 1selected stack(s). Viewing 4 1of1

¥t Stack viewed is 100.0% of selection
) ' g -~ 0
Function i S0 100.0% (28,3435 of 28.243s) |
- Caller Function Tree ~ - CPU Time:Self v Module —
- tachyon_find_hotspots.exelinitialize_2D_ ...
tachyon_find_hotspots.exe {8 tachyon_find_hotspots.exelzetup_2D_bu ...
F. setup_20_buffer ¢ render_one_pixel {198  25.943c M t=chyon_find_hotspots.exe tachyon_find_hotspots,exelrender_ane_..,
[ grid_intersect 16,7645 (N tachyon_find_hotspots.exe tachyon_find_hotspots,exe!draw_trace - ..
sphere_intersect 11.089s R tachyon_find_hotspots.exe tachyon_find_hotspots.exelthread_trace ...
[ video::main_loop 2.582: @ 3 tachyon_find_hotspots.exe tachyon_find_hotspots.exe!trace_shm(st...
[® grid_bounds_intersect 18731 tachyon_find_hotspots.exe tachyon_find_hotspots, exe!trace_region(..
[# Gdiplus::Graphics::DrawImage 0.754s 1) tachyon_find_hotspots.exe tachyon_find_hotspd je!renderscene(...
[+ shader 0.459s ) tachyon_find_hotspots.exe tachyon_ﬁnd_hotspm-;.:xe!rt_rendersFe B
tri_intersect 0.3285 ) tachyon_find_hotspots.exe tachyon_find_hotspats.exe :tachyon__\'lde =
[H pos2grid 0,229z tachyon_find_hotspots.exe tachyon_find_hotspots. exe!thread _video ...
Selected: 28.943s v
<l e
% Module:| [AI] | Thread:| [AIl | ¥ =
1 Function — Bottom-up Tree is the default Summary -~ 1 x
grouping level for hotspot data. Click the arrow Elapsed Time: 75,8095
I
button to change the grouping level. CPU Time: 54,5555
5 Unused CPU Time: 39.063s
. . . . Core Count: 2
2 Click the plus sign in front of the function name Threads Created: :

to view call stacks for the selected function.
Callers of the selected function are displayed,
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then callers of the first caller(s), and so on.
Double-clicking a stack opens the body of the
first caller function in the Source window.

CPU time is the active time taken to execute a function. For multiple threads, CPU time
is summed up. By default, this column is marked with a yellow star as the Data of
Interest column for the Hotspots Bottom-up window. This means that the data of this
column is used for different types of calculations, for example: call stack contribution,
percentage value on the filter toolbar.

Full stack information for the function selected in the grid. Yellow bar shows the
contribution of the selected stack to the hotspot function CPU time. Double-clicking a
stack function opens the body of this function in the Source window. The code line calling
the next function in the stack is highlighted.

Summary data on the analysis run: 1) Elapsed Time is the execution time of the
application from start to termination; 2) CPU Time is the sum of CPU time for all threads;
3) Unused CPU Time is the total time for each core when it was either waiting or not
utilized by the application; 4) Core Count is the logical CPU count for your machine;
5) Threads Created by your system during the application run.

Analyze the Most Time-consuming Functions

Analyze the CPU Time:Self column values in the Bottom-up window. By default, all data in the grid
is sorted by this column. Functions that took most CPU time to execute are listed on top. The first
functioninitialize_2D buffer took 28.943 seconds to execute. Click the plus sign # at the
initialize_2D buffer function to expand the stacks calling this function. You see that it was
called only once by the set up_2D buf f er function. You can analyze the Call Stack tab to find more
detailed information on the function sequence calling theinitialize 2D buffer function.

Theinitialize_2D buffer function is the biggest hotspot. Focus on this function to see if you
can find a way to improve its performance.

Recap

You identified a function that took the most CPU time and could be a good candidate for algorithm
tuning.
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Key Terms and Concepts

e Term: Elapsed time, CPU time

e Concept: Hotspots Analysis, Data of Interest

Analyze Code

.!a In the Bottom-up window, you identified i niti al i ze_2D buf f er as the hottest function. In
the Bottom-up window, double-click this function to open the Source window and analyze the source
code:

e Understand basic options provided in the Source window.
e Identify the hottest code lines.
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Understand Basic Source View Options

- r001hs - ¥
Hotspots
& Bottom-up | |&& Top-down Tree B find_hotspots.cpp X
®»®H 54
Line £ 3 Source CPU Time:Self kAl
|
79 d of £illing array
30 zddress ocrder
a1 R ey
a2 for (int i = 0; i < mem array i_max; it+)
83
84 for {int j = 0; j < mem array j_max; Jj++) 0.110s |
mem array [émem array j mexti] — *£ill value + 2;
a1 e bk e -
a2
a3
94 // Faster method of £illing array
95 The for loops are interchanged
96 ! IS5 £filled in consecutive memory =ddress order
a7 T T T
93 for (int J = 0; ] < mem array j_max; J++)
99
100 for {int i = 0; i < mem srray i_max; it++)
101
102 mem_arrey [j*mem srray j mex+i] = *£ill wvalue + Z;
103 }
104 }
105 Y
Selected (1 row(s)): 28.044s v
< | >
| Filter: 100% is shown Module:l[.-\ll] v|Thread:|[AII] v| Process:|[.-5\||] v| &’{7

The table below explains some of the features available in the Source window when viewing the
Hotspots analysis data.

Source pane displaying the source code of the application if the function symbol information
is available. The code line that took the most CPU time to execute is highlighted. The source
code in the Source pane is not editable.

1

If the function symbol information is not available, the Assembly window opens displaying
assembler instructions for the selected hotspot function. To enable the Source view, make

sure to build the target properly.
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2 Processor time attributed to a particular code line. If the hotspot is a system function, its
time, by default, is attributed to the user function that called this system function.

3 Hotspot navigation buttons to switch between most performance-critical code lines. Hotspot
navigation is based on the metric column selected as a Data of Interest. For the Hotspots
analysis, this is CPU Time: Self.

4 Source file editor button to open and edit your code.

Identify the Hottest Code Lines

When you identify a hotspot in the serial code, you can make some changes in the code to tune the
algorithms and speed up that hotspot. Another option is to parallelize the sample code by adding
threads to the application so that it performs well on multi-core processors. This tutorial focuses on
algorithm tuning.

By default, when you double-click the hotspot in the Bottom-up window, Amplifier opens the source
file related to this function highlighting the code line that took the most CPU time. For the
initialize_2D buffer function, the hottest code line is 86. This code is used to initialize a memory

array using non-sequential memory locations. Click the Source Editor button on the Source
window toolbar to open the default code editor and work on optimising the code.

Recap

You identified the code section that took the most CPU time to execute.

Key Terms and Concepts

e Term: hotspot, CPU time

e Concept: Hotspots Analysis, Data of Interest

Tune Algorithms

In the Source window, you identified that in thei ni ti al i ze_2D buff er hotspot function the code
line 86 took the most CPU time. Focus on this line and do the following:

e Open the code editor.
e Resolve the performance problem using any of these options:
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e Optimize the algorithm used in this code section.
e Recompile the code with the Intel® Compiler.

Open the Code Editor

Click the Source Editor button to open the fi nd_hot spot s. cpp file in the default code editor at
the hotspot line:

TTE vold initialize 2D buffer (unsigned int mem array [], unsigned int *fill wvalue)
80 v is NOT filled in consec ory address order
B2 for (int i = 0; i < mem array i mex ++)

B4 for (int J = 07 3 < mem array_J_max; J++)

86 mem array [j*mem array j max+i] = *fill walue + 2:
GUE] R REE AR AR AR EERRARERAREAREAAERAAAA

52

36 v address order

98 ;3 < mem array j_max; J

100 for (int 1 = 0; 1 < mem array_i_maxr; 1++)

102 mem array [j*mem array j max+i] = *fill wvalue + 2:
106

The hotspot line is used to initialize a memory array using non-sequential memory locations. For
demonstration purposes, the code lines are commented as a slower method of filling the array.

Resolve the Problem
To resolve this issue, use one of the following methods:

Option 1: Optimize your algorithm
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1. Edit line 81 to comment out code lines 82-88 marked as a "First (slower) method".
2. Edit line 97 to uncomment code lines 98-104 marked as a "Faster method".

In this step, you interchange the f or loops to initialize the code in sequential memory locations.
3. From the Visual Studio menu, select Build > Rebuild find_hotspots.

The project is rebuilt.

4. From Visual Studio Debug menu, select Start Without Debugging to run the application.

M tachyon_find_hotspots.exe CPU Time: 56.563 seconds.

Visual Studio runs the t achyon_fi nd_hot spot s. exe. Note that execution time has reduced
from 64.687 seconds to 56.563 seconds.

Option 2: Recompile the code with Intel® Compiler
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1

This option assumes that you have Intel® Parallel Composer installed. Composer is part of Intel®

Parallel Studio. By default, the Intel® Compiler, one of the Composer's components, uses powerful
optimization switches, which typically provides some gain in performance. For more details on the
Intel compiler, see the Intel Parallel Composer documentation.

As an alternative, you may consider running the default Microsoft Visual Studio compiler applying
more aggressive optimization switches.

To recompile the code with the Intel compiler:

1. From Visual Studio Project menu, select Intel Parallel Composer > Use Intel C++....

@% tachyon_ParallelStudio - Microsoft Visual Studio

Project | Buld Debug Tools Window Community Help

File Edit Wiew

(3 - i - (5 [} | Add Dass... Bse + Win32
Profile Hg =3 Add New Item... Ctrl+shift+A & .
. . balle
i Solution Explorer| 32 Add Existing Item. ., Shift+Alt+A ‘pp | rO00hs
7 = [E Exclude From Praoject
g | [ Solution 'taq 51| Show All Files oo e e
= || B L5 Amplifig i for (int i = 0; i <€ mem
g 33 ana Set as StartUp Project
;._ = 33 fin Project Dependencies. .. for {int 3 = 0; 3 <
j F Project Build Order...
8 3
g e | Intel Parallel Compaser 3 ||:3§ Use Intel C++...
o
h =
J Intel ¥Tune Amplifier XE 2011 Project Properties Select Build Components

Intel Parallel Amplifier 2011 Project Properties

2. In the Confirmation window, click OK to confirm your choice.

The project in Solution Explorer appears with the Composer icon:

33



1 Intel(R) Parallel Amplifier 2011 for Windows* OS Getting Started Tutorials

Solution Explaorer - find_hotspots > 1 X
_: Solution “tachyon_ParallelStudio’ (10 projects)
& i Amplifier

E analyze_locks
= find_hotspots
=2 33 find_hotspots
€+ find_hotspots.cpp
] find_hotspots.h
E identify_concurrency
i Composer
Inspector
33 tachyon.comman

3. From the Visual Studio menu, select Build > Rebuild find_hotspots.
The project is rebuilt with the Intel Compiler.
4. From the Visual Studio menu, select Debug > Start Without Debugging.

Visual Studio runs the t achyon_fi nd_hot spot s. exe. Note that the execution time reduced from
64.687 to 58.672 seconds.

Recap

You interchanged the loops in the hotspot function, rebuilt the application, and got performance gain
of 6-8 seconds. You also considered an alternative optimization technique using the Intel C++
compiler.

Key Terms and Concepts

e Term: hotspot

Compare with Previous Result

You made sure that the loop interchange mechanism you applied to optimize your code gave you

6-8 seconds of improvement in the application execution time. To understand whether you got rid
of the hotspot and what kind of optimization you got per function, re-run the Hotspots analysis on
the optimized code and compare results:

e Compare results before and after optimization.
e Identify the performance gain.
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Compare Results Before and After Optimization

1. Run the Hotspots analysis on the modified code.

2. Click the button on the Amplifier toolbar.

The Compare Results dialog box opens.

3. Specify the Hotspots analysis results you want to compare:

Compare results

Result 1: | V| [ Browse... ]
Result 2: | 00 ths.zmpl v| [ Browse... |

These results can be compared, Click 'Compare' to continue

Swap Results

I Compare l [ Cancel ]

The Hotspots Bottom-up window opens, showing the CPU time usage across the two results and
the differences side by side:

r000hs | r001hs ./ r000hs-r001hs | find_hotspots.cpp - X
Hotspots

Function hd CPU Time:Self: r000hs G CPU Time:Self: r001hs CPU Time:Self:Difference v Module 2
grid_intersect 10 7645 15 353 1 —‘IIB ] tachyon_| ﬁnd hotspots exe | —
Gdiplus::Graphics:: Drawimage 0.784s l 0.218s | 0.546s | tachyon_find_hotspats.exe
intersect_objects 0.172s r 1 0.064s z 0.108s , tachyon_find_hotspots.exe
ColorScale 0.157s i 0.0%1s 0 0.066s tachyon_find_hotspots.exe
GetString 0.062s | Os 0.062s | tachyon_find_hotspats.exe
light_intersect 0.140s | 0.086s | 0.054s | tachyen_find_hotspats.exe
shader 0.453s | 0.410s ] 0.043s | tachyon_find_hotspots.exe
shade_reflection 0.031s | 0.011s | 0.021s | tachyon_find_hotspots.exe
_SEH_prolog4 0.016s | Os 0.016s | MsvCRa0.dI
Winlnit 0.0168 | s 0.0168 | tachvon find hotsoats,exe

Selected: 28.943s 22,427 6.517s v

S5 L3

o I'~'10du|e:| [All] v | Thread:| [All] vl Process:| [All] v| ¥
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1 CPU time for the initial version of the Summary -« 1 x

tachyon_fi nd_hot spot s. exe application. i r00Chs ro0ihs  Diff.
Elapsed Time: 75.80%9s 68,9525 7.857s
. - . CPLU Time: 64.5565 53.520 6.0365
2 CPU time fqr the optimized version of the e T 0 (55 TE. T G50
tachyon_fi nd_hot spot s. exe. Core Count: 2 2 0
Threads Created: 3 3 i

3 Difference in CPU time between the two results in the 4

following format: <Difference CPU Time> = <Result 1
CPU Time> - <Result 2 CPU Time>.

4 Comparison summary data for the two results and their
difference calculated as r000hs - r001hs= Diff.

Identify the Performance Gain

Compare CPU time data for the first hotspot. 28.943s - 22.427s = 6.517s, which means that you
got the optimization of 6.5 seconds fortheini ti al i ze_2D buffer function. The Elapsed time also
shows about 8 seconds of optimization for the whole application execution.

Recap

You ran the Hotspots analysis on the optimized code and compared the results before and after
optimization using the Compare mode of the Amplifier. Compare analysis results regularly to look
for regressions and to track how incremental changes to the code affect its performance. You may
also want to use the Amplifier command-line interface and run the anpl - cI| command to test your
code for regressions. For more details, see the Command-line Interface Support section in the
Amplifier online help.

Key Terms and Concepts

e Term: hotspot, Elapsed time, CPU time

e Concept: Hotspots Analysis

Summary

You have completed the Finding Hotspots tutorial. Here are some important things to remember
when using the Amplifier to analyze your code for hotspots:
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Step 1. Choose and Build Your Target

Configure the Microsoft* symbol server and your project properties to get the most accurate
results for system and user binaries and to analyze the performance of your application at the
code line level.

Create a performance baseline to compare the application versions before and after optimization.
Make sure to use the same workload for each application run.

Step 2. Run Analysis

Use the Amplifier toolbar or Tools menu to choose and run the analysis. You can also use the
anmpl - cl command.

If required, modify the default analysis settings from Tools > Options... > Intel Parallel
Amplifier 2011 > Collection. For example, you may limit the data collection to a predefined
amount of data or enable the Amplifier to collect more accurate CPU time data.

Step 3. Interpret Results and Resolve the Issue

Start analyzing the performance of your application from the Summary tab to explore the
performance metrics for the whole application. Then, move to the Bottom-up window to analyze
the performance per function. Focus on the hotspots - functions that took the most CPU time -,
by default, located at the top of the window.

Double-click the hotspot function in the Bottom-up window or Call Stack tab to open its source
code at the code line that took the most CPU time.

Consider using Intel® Compiler, part of the Intel® Parallel Composer, to optimize your tuning
algorithms. Explore the compiler documentation for more details.

Step 4. Compare Results Before and After Optimization

Perform regular regression testing by comparing analysis results before and after optimization.

From GUI, click the Compare Results button on the Amplifier toolbar. From command line,
use the anpl - cl command.
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Intel® Parallel Amplifier
Tutorial: Identifying Concurrency

Learning Objectives

This tutorial shows how to use the Concurrency analysis of the Intel® Parallel Amplifier to understand
whether your application effectively utilizes all available cores and identify the most serial code to parallelize.
Ideal processor utilization occurs when the number of running threads equals the number of available
cores. You have to focus on the hotspots with poor processor utilization and make all processor cores
work. If you have a hotspot where cores are idle, consider adding parallelism, rebalancing or reducing
contention.

Estimated completion time: 15 minutes.
After you complete this tutorial, you should be able to:

e Choose an analysis target.

e Run the Concurrency analysis.

e Estimate the concurrency level in your application.

¢ Identify the most time-consuming functions with poor CPU utilization.
e Analyze the source code to locate the most critical code lines.

e Compare results before and after optimization.

Workflow Steps to Analyze CPU Utilization

You can use the Intel® Parallel Amplifier to understand how your application utilized available cores by
performing a series of steps in a workflow. This tutorial guides you through these workflow steps while
using a sample ray-tracer application named t achyon.

D NOTE. Click [ ShowMe ] for a video demonstration. Show Me videos require Adobe* Flash*
Player.
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Choose target

Build target

Run Concurrency
analysis

Interpret results

Interpret results _._E]Cnmpare w'thg)

revious result

View source

¥

NN  Parallelize code

1. Choose a target to analyze for concurrency.

2. Configure environment and project settings and build the target.
3. Run the Concurrency analysis.

4. Interpret the result data.

5. View and analyze code of the performance-critical function.

6. Modify the code to add parallelism.

7. Re-build the target, re-run the Concurrency analysis, and compare the result data before and
after optimization.
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Choose Target

Before you start, you need to choose your analysis target in the Microsoft Visual Studio* environment.
For this tutorial, your target is a ray-tracer application, t achyon. To learn how to install and set up

the sample code, see Prerequisites.

0

NOTE. The steps below are provided for Microsoft Visual Studio 2005. They may slightly
differ for other versions of Visual Studio.

To choose a project:

1. From the Visual Studio menu, select File > Open > Project/Solution....
The Open Project dialog box opens.

2. In the Open Project dialog box, to the location you used to unzip the t achyon_st udi o. zi p file
and select the t achyon_Par al | el St udi o. sl n file.

3

#9 tachyon_ParallelStudio - Microsoft Visual St

The solution is added to Visual Studio and shows up in the Solution Explorer.

In Solution Explorer, right-click the identify_concurrency project and select Project > Set as

xogoo | S | Jeuo)dx 3 seies

File Edit Wew Project Build Debug Tools
i1- - 25

[E Profile Comcurrency -Whereism » B 01 3%
1| Solution Explorer - Amplifier

[= BIF WCENE

B

: Solution 'tachyon_ParallelStudio’ (10 projects)
= &7 Amplifier

33 analyze_locks

33 find_hotspots
33 identify_concurrency

EaREa

35 tachyon.comman

StartUp Project.

identify_concurrency appears in bold in Solution Explorer.

> 1 X

a1
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Recap

You selected the identify_concurrency project as the target for the Concurrency analysis.

Key Terms and Concepts

e Term: target

Build Target

After choosing the analysis target, do the followig to ensure the Intel® Parallel Amplifier provides the
most accurate information on the performance of your application:

e Build the target in the release mode with full optimizations, which is recommended for performance
analysis.

e Run the application without debugging to create a performance baseline.

e Configure the Microsoft Visual Studio* environment to download the debug information for system
libraries so that Amplifier can properly identify system functions and classify and attribute functions.

e Configure Visual Studio project properties to generate the debug information for your application
so that Amplifier can open the source code.

D NOTE. The steps below are provided for Microsoft Visual Studio 2005. They may slightly
differ for other versions of Visual Studio.

Choose a Build Mode and Build a Target

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your
target project.

2. From the Visual Studio menu, select Build > Build identify_concurrency.

The tachyon_identify_concurrency. exe application is built.

Create a Performance Baseline

1. From the Visual Studio menu, select Debug > Start Without Debugging.

The tachyon_i denti fy_concurrency. exe application runs in multiple sections depending on
the number of CPUs in your system.
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u NOTE. To get more accurate results, before you start the application, minimize the
amount of other software running on your computer and disconnect from the network.

M tachyon_identify_concurrency.exe CPU Time: 32.641 seconds.

2. Note the execution time displayed in the window caption. For
tachyon_i dentify_concurrency. exe, the execution time is 32.641 seconds. The total execution
time is the baseline against which you will compare subsequent runs of the application.

D NOTE. Run the application several times, note the execution time for each run, and use
the average number. This helps to minimize skewed results due to transient system
activity.
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Enable Downloading the Debug Information for System Libraries

1. Go to Tools > Options....
The Options dialog box opens.
2. From the left pane, select Debugging > Symbols.

3.
In the Symbol file (.pdb) locations field, click the button and specify the following address:
http://msdl.microsoft.com/download/symbols.

4. Make sure the added address is checked.

5. In the Cache symbols from symbol servers to this directory field, specify a directory where
the downloaded symbol files will be stored.

6. For Microsoft* Visual Studio* 2005, check the Load symbols using the updated settings when
this dialog is closed box.
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7. Click Ok.

Enable Generating Debug Information for Your Binary Files

1. Select the identify_concurrency project and go to Project > Properties.

2. From the identify_concurrency Property Pages dialog box, select Configuration Properties
> General and make sure the selected Configuration (top of the dialog) is Active(Release).

3. From the identify_concurrency Property Pages dialog box, select C/C++ > General pane
and specify the Debug Information Format as Program Database (/Zi).
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4. From the identify_concurrency Property Pages dialog box, select Linker > Debugging and
set the Generate Debug Info option to Yes (/DEBUG).

identify_concurrency Property Pages

Configuration: |Acﬁve(Re|ease}

b | Platfarm: | Active(Win32)

[=)- Comman Properties
References
= Configuration Properties
General
Debugging
Cfc++
= Linker
General
Input
Manifest File
System
Optimization
Embedded IDL
Adwanced
Command Line
Manifest Tool
XML Document Generator
Browse Information
Build Events
Custom Build Step
WWeb Deployment

B E-E-E-E-E

V| [ Configuration Manager... ]

Generate Debug Info

Generate Program Database File
Strip Private Symbols

Generate Map File

Map File Name

Map Exports

Debuggable Assembly

Generate Debug Info

Enables generation of debug infarmation.

Yes (/DEBUG)
&(TargetDir)s{TargetMame). pdb

Mo

Mo
Mo Debuggable attribute emitted

(/DEBUG)

I Ok l [ Cancel

Recap

You chose the target for the Concurrency analysis, set up your environment to enable generating
symbol information for system libraries and your binary files, built the target in the Release mode,
and created the performance baseline. Your application is ready for analysis.

Key Terms and Concepts

e Term: target, baseline
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e Concept: Concurrency Analysis

Run Concurrency Analysis

After building the target, you can run it to analyze its performance. In this tutorial, you run the
Concurrency analysis to identify the most serial code to parallelize.

To run an analysis:

1. From the Amplifier toolbar, select Concurrency — Where is my concurrency poor?

F‘ru:nﬁle Hotspots - Where is my p v| B il ¥ dJB Compare

identify_conc Hotspots - Where is my program spending time?
- - Where is my concurrency poor?

Vs > I'\"n'l i - l\u"n" i fl W iti H

raw_task Locks and Waits - Where is my program waiting?

2. Click the Profile button.

The Amplifier launches t achyon_i denti fy_concurrency. exe that renders bal | s. dat as an
input file, calculates the elapsed time, and exits. The Amplifier finalizes the collected data and
opens the results in the Concurrency reslt tab.

D NOTE. To make sure the performance of the application is repeatable, go through the
entire tuning process on the same system with a minimal amount of other software
executing.
Recap

You ran the Concurrency data collection that analyzes CPU time spent in each program unit of your
application and estimates whether your application utilizes available logical CPUs effectively.

ﬂ NOTE. This tutorial explains how to run an analysis from the Amplifier graphical user
interface (GUI). You can also use the Amplifier command-line interface (anpl - cl
command) to run an analysis. For more details, check the Command-line Interface
Support section of the Amplifier Help.

Key Terms and Concepts

e Term: hotspot

e Concept: Concurrency Analysis, Finalization
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Interpret Result Data

When the sample application exits, the Intel® Parallel Amplifier finalizes the results and opens
the Concurrency window showing the call stack with functions ordered bottom-up. Follow these steps
to interpret the concurrency data:

e Understand the basic performance metrics provided by the Concurrency analysis.

e Identify functions with poor CPU utilization.

D NOTE. The screenshots and execution time data provided in this tutorial are created on
a system with two CPU cores. Your data may vary depending on the number and type
of CPU cores on your system.

Understand the Basic Concurrency Metrics

~1002cc|” identify_concurrency.cpp ~ || Summary > 1 X
: Elapsed Time: 44,441z
Concurrency ' CPU Time: 33,7975
& Top-down Tree Wait Time: 117.13%s
2 Wait Count: 3654
Function . CPU Time by Utilization:Self B 2 LrisREr s S
- Caller Function Tree Module Core Count: 2
Oide BMPoor Ok Bideal @ oOwe I Threads Created: 4
357 |tachyon identfy_concurrency.exe fiem
sphere_intersect 9.611s [N tachyon_identify_concurrency.exe
draw_task::operator ) 2,945 [N tachyon_identify_concurrency.exe
[# grid_bounds_intersect 1.693s I 1 tachyon_identify_concurrency.exs
pos2grid 0.347= tachyon_identify_concurrency.exe
hader 0.300s1 tachyon_identify_concurrency.exe
[HVScale 0.154s| tachyon_identify_concurrency.exe
Raypnt 0,145 | tachyon_identify_concurrency exe
tri_intersect 0,131 tachyon_identify_concurrency.exe
Selected: 13.157s bl
22 b3
% Module:  [Al] ~ | Thread: | [an] v| ¥ s
1 The utilization of the processor time per program unit (function, by default). By default,

the functions are sorted by Poor processor utilization type. Bars showing OK or Ideal
utilization (orange and green) are utilizing the processors well. You should focus your

optimization efforts on functions with the longest poor CPU utilization (red B bars if the
bar format is selected). Next, search for the longest over-utilized time (blue @ bars).
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This is the Data of Interest column for the concurrency analysis results. This means that
the data of this column is used for different types of calculations, for example: call stack
contribution, percentage value on the filter toolbar.

2 Summary data on the application performance: 1) Elapsed Time is the execution time
of the application from start to termination; 2) CPU Time is the sum of CPU time for all
threads; 3) Wait Time is the amount of time the application threads waited for some
event to occur, such as synchronization waits and I/0 waits; 4) Wait Count is the overall
number of times the system wait API was called for the analyzed application; 5) Unused
CPU Time is the total time for each core when it was either waiting or not utilized by the
application; 6) Core Count is the logical CPU count for your machine; 5) Threads Created
by your system during the application run.

3 Graph representing the Elapsed time and utilization level for the specified number of
running threads. Ideally, your graph nodes should be within the Ok or Ideal utilization
range.

D NOTE. OK utilization level is not available on systems with a small number of
cores.

The Target Concurrency value, by default, is equal to the number of physical cores.
Consider this number as your optimization goal.

Average CPU Usage is calculated as CPU time / Elapsed time. Use this number as a
baseline for your performance measurements. The closer this number to the number of
cores, the better.

Identify Functions with Poor CPU Utilization

Start with analyzing the data provided in the Summary tab. The Summary tab shows that
tachyon_i denti fy_concurrency. exe is a multithreaded application running three threads on a
machine with two cores. But it is not using available cores effectively. The Average CPU Usage on
the graph is about 1 while your target should be making it as closer to 2 as possible (for the system
with 2 cores).

Hover over the second graph node to understand how long the application ran serially:
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; The tooltip shows that the application ran one thread for
A almost 35 seconds, which is classified as Poor CPU
For 35,370s the application h:ad poor CPU utilization with 1 Utl |iZatiO|’] .

running or runnable thread(s).

S\ 5 The Concurrency Bottom-up window identifies the
grid_intersect function as the biggest hotspot. The red
bars in the CPU Time by Utilization column indicate that
most of the time processor cores were underutilized.

Click the plus sign # at the gri d_i nt er sect function in the
Bottom-up window to expand the list of call stacks. You see three
major call stacks.

F. shader + trace 3.933: N
H . trace 4.827s (NN
F. grid_intersect 0.540: @

The most time-critical call stack ends with the shader
function.

Select this call stack in the Bottom-up window and explore the Call Stack tab that displays the call
sequence to the gri d_i nt er sect function. Knowing the code, you may guess that the dr aw_t ask
function could be the source of the bad concurrency. Double-click the function in the Call Stack tab
to go to the source of this function and look for potential issues there.

Call Stack ~ 1 X

10 selected stack(s), viewing <1 1of 10 [
FrStack viewed is 33.4% of selection
[ 33,4% (3.001s of 8.938s)

=

tachyon_identify_concurrency.exelgrid_intersect - grid.cpp
tachyon_identify_concurrency.exe!shader{struct ray *) - shade.cpp: 139
tachyon_identify_concurrency.exeltrace(struct ray ) - trace_rest.cpp: 77
tachyon ||:Ient|1"y _concurrency.exelrender onEmeeI |dent|f'y _concurrency.cpp: 105

ss thb::blodked range<int> const &) - identi

pp-
tachyon_identify_concurrency.exelthb:iinternali:start_for<class thb::blocked_range <int=,class draw_task,class thb: autu:u:nartl
tachyon_identify_concurrency.exe!thread_trace(struct thr_parms *) - identify_concurrency. cpp: 207
tachyon_identify_concurrency.exe!trace_shm{struct scenedef int,int,int,int) - trace_rest.cpp: 110
tachyon_identify_concurrency.exeltrace_region(struct scenedef, void *,int,int,int,int) - trace_rest.cpp: 123
tachyon_identify_concurrency.exelrenderscene(struct scenedef) - render.cppig3
tachyon_identify_concurrency.exe!tachyon_video: :on_process(void) - video.cpp: 159
tachyon_identify_concurrency.exe!thread _video{void *) - winvideo.h: 133
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Recap

You identified a hotspot function that has the worst CPU utilization and could be a good candidate
for adding parallelism. You explored the call sequences to the hotspot function and found the function
that could introduce bad concurrency. Your next step is to analyze the code of this function.

Key Terms and Concepts

e Term: Elapsed time, CPU time
e Concept: Concurrency Analysis, CPU Utilization, Data of Interest

Analyze Code

You identified thattheinitial i ze_2D buff er function took the most CPU time with poor processor
utilization. Analyzing the stack calling this function, you discovered the dr aw_t ask function that
potentially could cause performance problems. Double-click the dr aw_t ask function in the Call Stack
tab to open the Source window and analyze the code of this function:

e Understand basic options provided in the Source window.
e Identify the hottest code lines.
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Understand Basic Source View Options

r002cc|” identify_concurrency.cpp -~ X

Concurrency

Cﬁ Bottom-up Cﬁ Top-down Tree B: identify_concurren... %

) ®» B8
CPU Time by Utilization:Self L o]
Line Source
Bide @Foor DOk M Ideal @ Over

165

166 for (int y=r.begin(); yl!=r.emnd(); ++v) [

167 drawing sres drawing|ssarsx, totsly-y, stopm-ssers, 1); 1

168 3

169 /¢ Enter Critical Section to protect pixel calculation from multithreaded access (Needed?)

170 TnterCriticalSection(irgh_criticsl section); 3.521s
71

172 for (int x = startx; x < stopx; x++) {

color © c = render ome pixel (x, y, local mbox, serial, startx, A S —
174 drawing.put_pixelic);
175 2 3
176
177, /¢ Exit from the critical section
173 LeaveCriticalSection(srgh critical secticon); 0.443s
179
180 if (lvidec—ynext_frame()) tbb::task::self().cancel group executicn(); L
181 }
182 }
Selected (1 row{s)): b
L] I B &
¢ |Filter: 100% is shown | Module: | [all ~ | Thread: | [All || Utilization: | [All] w | Process:| [All] w %

The table below explains some of the features available in the Source window when viewing the
Concurrency analysis data.

1 Source code of the application displayed if the function symbol information is available. If
you go to the source by double-clicking the hotspot function in the Bottom-up window, the
code line that took the most CPU time to execute this function is highlighted. The source
code in the Source window is not editable.

If the function symbol information is not available, the Assembly window opens displaying
assembler instructions for the selected wait function. To enable the Source view, make sure
to build the target properly.

2 Function call site. If you go to the source from the stack function, the Source window
highlights the code line that called the next function from the stack and marks this call site
with an yellow arrow.

3 Processor time and CPU utilization bar attributed to a particular code line. The colored bar
represents the utilization of the available CPU time according to the Amplifier-defined
utilization levels (Idle, Poor, Ok, Ideal, and Over). The longer the bar, the higher the value.
Ok utilization level is not available for systems with a small number of cores.
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4 Hotspot navigation buttons to switch between most performance-critical code lines. Hotspot
navigation is based on the metric column selected as a Data of Interest. For the Concurrency
analysis, this is CPU Time by Utilization : Self.

5 Source file editor button to open and edit your code in the Visual Studio editor.

Identify the Hottest Code Lines

Click the Hotspot navigation button on the Source window toolbar to go to largest hotspot in the
dr aw_t ask function. The Amplifier highlights line 170 entering the critical section rgb_criti cal
sect i on. Executing this line took about 3.5 seconds and most of the time the processor was

underutilized. Click the Hotspot navigation button to go to the next hotspot in the function. The
Amplifier highlights line 178 where the critical section exits.

Thergb_critical section isthe place where the application is serializing. Each thread has to
wait for the critical section to be available before it can proceed. Only one thread can be in the critical

section at a time. You need to optimize the code to make it more concurrent. Click the Source
Editor button on the Source window toolbar to open the Visual Studio editor and work on optimizating
the code.

Recap

You identified the code section that took the most CPU time to execute and significantly underutilized
processor cores.

Key Terms and Concepts

e Term: CPU time

e Concept: CPU Utilization, Concurrency Analysis, Data of Interest

Add Parallelism

In the Source window, you identified that in the dr aw_t ask function the code line 170 underutilized
the processor cores significantly and took the most CPU time to execute. Focus on this line and do
the following:

e Open the code editor.
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e Modify the code to add parallelism.

Open the Code Editor

Click the Source Editor button to open the i denti fy_concurrency. cpp file in the Visual Studio
editor at the hotspot line:

“1§ draw_task ~ | |5 operator {const thb::blocked _range<ints &r) const N
163 unsigned int * local mbox = (unsigned int *) alloca(mboxsize); f
1 memset (local mbox, 0,mboxsize);
1 for Fl=r.end(); ++y¥) {
1 g(startx, totaly-y, stopx-startx, 1);
169 ect pixel calculation from mumltithreaded access (Needed?
170 cal_section);
172 for (int X = STartx; X < STODX; X++) {
1 r_t c = render one_pixel (x, ¥, local_mbox, serial, startx, StopX, STarty, STODY):
1 drawing.put_pixel (c):
1 /f Exit from the critical =ection
178 LeaveCriticalSection(&argb critical section):
180 if (!video->next_ frame()) tbb::task::self().cancel group execution():;
182
1 draw_task () {}
1880 static wvoid parallel thread (void) { 2
-il — — — S—
< >

Modify the Code to Add Parallelism

The rgb_critical _section was introduced to protect calculation from multithreaded access. The
code is actually thread safe and the critical section is not really needed.

To resolve this issue:
1. Comment out code lines 170 and 178 to disable the critical section.
2. From Solution Explorer, select the identify_concurrency project.
3. From Visual Studio menu, select Build > Rebuild identify_concurrency.
The project is rebuilt.
4. From Visual Studio menu, select Debug > Start Without Debugging to run the application.
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Visual Studio runs thet achyon_i denti fy_concurrency. exe. Note that execution time reduced
from 32 seconds to 19.5 seconds.

M tachyon_identify_concurrency.exe CPU Time: 19.547 seconds.

Recap

You optimized the application execution time by removing the unnecessary critical section that
consumed a lot of CPU time.

Key Terms and Concepts

e Term: hotspot
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Compare with Previous Result

You made sure that removing the critical section gave you 12.5 seconds of optimization in the
application execution time. To understand the impact of your changes per function and how the CPU
utilization has changed, re-run the Concurrency analysis on the optimized code and compare results:

e Compare results before and after optimization.
e Identify the performance gain.

Compare Results Before and After Optimization
1. Run the Concurrency analysis on the modified code.

2. Click the button on the Amplifier toolbar.

The Compare Results dialog box opens.
3. Specify the Concurrency analysis results you want to compare and click the Compare button:

Compare results

Result 1: | r002cc,ampl v| [ Browse... |

Resuit 2: | r003cc.ampl v| [ Erowse... |

These results can be compared. Click "Compare' to continue

Swap Results

I Compare l [ Cancel ]

The Concurrency Bottom-up window opens, showing the CPU time utilization across the two results
and the differences side by side:
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2

r002cc-r003cc

Concurrency

Function b Module
Dide BPoor OOk Blidesl @Over @Ide WPoor DOk BIdesl @over e  Poorw | Ok Ideal | Over
arid_intersect 16.090s 16,6345 /i 0s 12.890s Os -10.638s -2.797s tachyon_identify_concurrency.exe
sphere_intersect 11.801s [ ] 13.021s [ ] 0s  5.135s Os| -B.836s| -1.569s tachyon_identify_concurrency.exe
grid_bounds_intersect 2.264% [ ] 1.835s B 0s 1722 Os| -1.194s| -0.199s tachyon_identify_concurrency.exe
pos2grid 0.433s 1 0.522s 1 0s  0.324 Os| -0.289s -0.124s tachyon_identify_concurrency.exe
draw_task::operator ) 0.278s 1 0.016s | 0s| 0.256s Os  0.008s 0s | tachyon_identify_concurrency.exe
shader 0.40%s 1 1 0.435s 12 0s  0.250s s/ -0.198s| -0.128s|tachyon_identify_concurrency.exe
tri_intersect 0.345s 1 0.3158 ] 0s| 0.232 : -0.084s| -0.118s | tachyon_identify_concurrency.exe
shade_phaong 0.1588 | 0. 1468 | 0 0,142 Os| -0.115s| -0.015s tachyon_identify_concurrency.exe
trace 0.157s | 0.161s | Os| 0.110s 0s| -0.113s| -0.001s| tachyon_identify_concurrency.exe
tri_normal 0.046s | 0.082s ] 0s| 0.048s Os| -0.033s| -0.049s tachyon_identify_concurrency.exe
[Unknown frame(s)] 0.045s | 0.013s | Os| 0.045s Os 0s| -0.013s| [Unknown]
render_one_pixel 0.031s | 0.073s I 0s| 0.031s Os| -0.016s| -0.062s tachyon_identify_concurrency.exe
stringcmp 0.047s | 0.018s | 0s 0.031s Os Os 0Os tachyon_identify_concurrency.exe
light_intersect 0.063s ] 0.141s | 0s| 0.016s Os| -0.109s| 0.015s tachyon_identify_concurrency.exe
sphere_normal 0.016s | 0.044s | ds  0.016s Os| -0.017s| -0.027s tachyon_identify_concurrency.exe
GetObject 0.016s | 0s 0| 0.016s Os s 0s | tachyon_identify_concurrency.exe
WinInit 0.018s | Os 0s| 0.016s Os 0s 0g tachvon identifv concurrency.exe
Selected: 16.090s 16.634s Os| 12.890s Os| -10.638s -2.797s

< <€ >

3% |Filter: 100% is shown | Module:| [All] || Thread: | [All] || Utilization: | [Al] | Process: | [Alll w %
1 CPU time for the initial version of the code. Summary

w ro02cc
Elapsed Time:
2 CPU time for the optimized version of the code. CPU Time:
Wait Time:
‘ Wait Count: 2764

3 Difference in CPU time per utilization level between the Logical CPUs Utiized: 1.13

identify_concurrency.cpp

Start Page

CPU Time by Utilization:Self: r002cc w CPU Time by Utilization:Self: r003cc

CPU Time by Utiization: Self:Difference

two results in the following format: <Difference CPU

Time> = <Result 1 CPU Time> - <Result 2 CPU Time>.
By default, the Difference column is expanded to display
comparison data per utilization level. You may collapse

the column to see the total difference data per CPU time.

Comparison summary data for the two results and their
difference calculated as r002cc - r003cc= Diff.

Logical CPUs Utilized is the average utilization of all
cores during application run.

Concurrency graphs for both compared results.

Identify the Performance Gain

Elapsed Time

Unused CPU Time:
Core Count:
Threads Created:

35.279s 36.867s
123.331s 65.574s 57.757s

> 0 X

ronz Diff.

-1,588s

2163 601

1.60 -0.47

38.722s 12.211s 26.512s
2 a

4 a

Click the E button for the first three columns to expand them per utilization level.
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r003cc./ P002cc-r003cc [ ro02cc | identify_concurrency.cpp | Start Page - X
Concurrency

CPU Time by Utiization:Self: r002cc ¥ CPU Time by Utlization:Self: r003cc CPU Time by Utilization: Self:Difference -~

Function v
Ide Poor Ok Ideal = Ower Idle Poor Ok Ideal Qver Ide | Poorw | Ok Ideal Over
sphere_intersect Os| 7.406s Os| 1.356s| 0.971s s Os Os| 8.232s| 2.632s Os| 7.406s Oz -6,878s  -1.660s tack
draw_task::operatar[) 0= 3.115¢ Oz 0.787s 0.062s i3 0= [ Oz 0.012s Oz 3.115 Oz 0.787s 0.050s tack
grid_bounds_intersect Os| 0.973s Os| 0.238s| 0.159s 0s Os Os| 1.083s| 0.337s Os| 0.973s Os| -0.845s | -0.178s|tack
pos2grid Os  0.258s Os 0.043s 0.032s i) 0= Os 0.282s 0.035s Os 0.2508s 0s| -0.23%s| -0.003s|tach
shader Os  0.246s Os 0.037s 0.038s 1] o] Os 0.374s 0.085s Os  0.246s 0Os| -0.337s| -0.047s|tach
shade_phong 0= 0.130s 0= 0= 0.011s i3 0= Oz 0.055s 0.010s 0= 0.130s 0= -0.055s 0.000s tack
trace Os| 0.101s Os Os| 0.046s Os Os Os| 0.089s| 0.042s Os| 0.101s 0s -0.06%s 0.004s tack
tri_intersect 0 0.034s ] Os| 0.058s i} o] Os| 0.155s| 0.073s 0 0.034s 0s| -0.155s| -0.017s|tach
render_one_pixel Oz 0.043s Os Os Os s Os Os  0.005s Os Os  0.043s Os -0.005s Os | tack
camray Os| 0.037= Os| 0.003s 0.011s Os Os Os 0.080s Os Os| 0.037= 0s| -0.076s| 0.011s tack
sphere_normal Os| 0,037 Os Os Os s Os Os 0.042s 0.011s Os 0.037s Os| -0.042s| -0.011s|tack
add_intersection 0s 0.032s ] 0s 0.011s i} o] Os| 0.015s| 0.011s 0s 0.032s 0s| -0.015s| 0.000s|tach
GetSphere Oz 0.084s Os Os Os s 0.032s Os s Os 0s 0.032s Os Os Os | tack
light_intersect Os| 0.029s Os| 0.011s| 0.004s s Os Os| 0.097s| 0.021s Os| 0.029s Os| -0.086s -0.013s tack
thread_trace Oz 0.048s Os Os Os Os 0.025s Os Os Os O0s| 0.021s Os Os Oz | tack
rt_sphere Os| 0.013s s Os Os s Os Os s Os 0s| 0.013s s Os 0Os | tack
InternalWndProc 0= 0.021s 1] 0= 0= Os| 0.01is Os Os  0.000s Os  0.010s 1] 0s -0.000s tach
engrid_object Os  0.003s Os Os Os s Os Os s Os O 0.003s Os Os Oz tack
Zdinluc s e amhice s Dirzi Tmana Ne nn3de Ne N 12% 0 274 e (N alelr Ne N 170 N E7% e N ANSe Ne N N13e .0 2070 tark
Selected: Os 11.207s Os 2.161s 1.287s 1] 0= O0s| 11.938s 2.976s Os 11.207s 0s| 9.777s| -1.680s v
< >< >
i Module: | [All] | Thread: | [Al] | Utlization:| [All] | Process:| [Al] - %

For the gri d_i nt er sect hotspot function, the difference is 11.207s - 0s = 11.207s of Poor CPU
utilization time, which means that this function in Result 2 (optimized) did not have Poor utilization
at all and effectively used processor cores. Respectively, the Ideal CPU utilization time has increased
significantly: 2.161s - 11.938s = -9.777s, which means that after removing the critical section all
CPU cores were effectively utilized during almost 10 seconds.

The Elapsed time data in the Summary tab shows the optimization of 13.940 seconds for the whole
application execution.

Recap

You ran the Concurrency analysis on the optimized code and compared the results before and after
optimization using the Compare mode of the Intel® Parallel Amplifier. The comparison shows that,
with the optimized version of the t achyon_i denti fy_concurrency. exe application (r003cc result),
you managed to better utilize all available cores and got 13-second speedup for the application
Elapsed time. Compare analysis results regularly to look for regressions and to track how incremental
changes to the code affect its performance. You may also want to use the Amplifier command-line
interface and run the anpl - cI| command to test your code for regressions. For more details, see the
Command-line Interface Support section in the Amplifier online help.
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Key Terms and Concepts

Term: hotspot

Concept: Concurrency Analysis

Summary

You have completed the Identifying Concurrency tutorial. Here are some important things to remember
when using the Amplifier to analyze your code for concurrency:

Step 1. Choose and Build Your Target

Configure the Microsoft* symbol server and your project properties to get the most accurate
results for system and user binaries and to analyze the performance of your application at the
code line level.

Create a performance baseline to compare the application versions before and after optimization.
Make sure to use the same workload for each application run.

Step 2. Run Analysis

Use the Amplifier toolbar or Tools menu to choose and run the analysis. You can also use the
anmpl - cl command.

If required, modify the default analysis settings from Tools > Options... > Intel Parallel
Amplifier 2011 > Collection. For example, you may limit the data collection to a predefined
amount of data or enable the Amplifier to collect more accurate CPU time data.

Step 3. Interpret Results and Resolve the Issue

Start analyzing the performance of your application from the Summary tab to explore the
performance metrics for the whole application. Then, move to the Bottom-up window to analyze
the performance per function. Focus on the hotspot functions that under- or over-utilized the
available logical CPUs during their execution and took the most CPU time. By default, the functions
that under-utilized available cores (Poor utilization level) most of all show up at the top of the
window.

Double-click the hotspot function in the Bottom-up window or Call Stack tab to open its source
code at the code line with the worst CPU utilization.
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Step 4. Compare Results Before and After Optimization

e Perform regular regression testing by comparing analysis results before and after optimization.

From GUI, click the Compare Results button on the Amplifier toolbar. From command line,
use the anpl - ¢l command.

e Expand each data column by clicking thel button to identify the performance gain per CPU
utilization level.
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Intel® Parallel Amplifier

Tutorial: Analyzing Locks and
Waits

Learning Objectives

This tutorial shows how to use the Locks and Waits analysis of the Intel® Parallel Amplifier to identify one
of the most common reasons for an inefficient parallel application - threads waiting too long on
synchronization objects (locks) while processor cores are underutilized. Focus your tuning efforts on
objects with long waits where the system is underutilized.

Estimated completion time: 15 minutes.

After you complete this tutorial, you should be able to:

Choose an analysis target.

Choose the Locks and Waits analysis type.

Run the Locks and Waits analysis.

Identify the synchronization objects with long waits and poor CPU utilization.
Analyze the source code to locate the most critical code lines.

Compare results before and after optimization.

Workflow Steps to Identify Locks and Waits

You can use the Intel® Parallel Amplifier to understand the cause of the ineffective processor utilization
by performing a series of steps in a workflow. This tutorial guides you through these workflow steps while
using a sample ray-tracer application named t achyon.

D NOTE. Click [ ShowMe ] for a video demonstration. Show Me videos require Adobe* Flash*

Player.
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Choose target

{Re)Build target

Run Locks and
Waits analysis

Interpret results
Compare with
Interpret results —I-

View source

i

7

1. Choose a target to analyze for locks and waits.

2. Configure environment and project settings and build the target.
3. Run the Locks and Waits analysis.

4. Interpret the result data.

5. View and analyze code of the performance-critical function.

6. Modify the code to remove the lock.

7. Re-build the target, re-run the Locks and Waits analysis, and compare the result data before and
after optimization.

Choose Target

Before you start you need to choose the target in the Microsoft Visual Studio* environment. For this
tutorial, your target is a ray-tracer application, t achyon. To learn how to install and set up the
sample code, see Prerequisites.

D NOTE. The steps below are provided for Microsoft Visual Studio* 2005. Steps for other
versions of Visual Studio IDE may slightly differ. See online help for details.
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To choose a target:

1. From the Visual Studio menu, select File > Open > Project/Solution....
The Open Project dialog box opens.

2. In the Open Project dialog box, browse to the location you used to unzip the
t achyon_st udi o. zi p file and select the t achyon_Par al | el St udi o. sl n file.

#9 tachyon_ParallelStudio - Microsoft Visual St

File Edit Wew Project Build Debug Tools W
RSERA= A= - A -
Proﬁle Concurrency - Whereism ~ B 01 3%

I_'lill' Solution Explorer - Amplifier -~ 0 %
2 ILE

% || [ solution 'tachyon_ParallelStudi’ (10 projects)
m -, B -

= || B~ i Amplifier

=) 24 analyze_locks

o

= 33 find_hotspots

>§' 33 identify_concurrency

g i % Composer

= i Inspector

35 tachyon.common

The solution is added to Visual Studio and shows up in the Solution Explorer.

3. In Solution Explorer, right-click the analyze_locks project and select Project > Set as StartUp
Project.

analyze_locks appears in bold in Solution Explorer.

Recap

You selected the analyze_locks project as the target for the Locks and Waits analysis.

Key Terms and Concepts

e Term: target
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Build Target

After choosing the analysis target, do the following to ensure the Intel® Parallel Amplifier provides
the most accurate information on the performance of your application:

e Build the target in the release mode with full optimizations, which is recommended for performance
analysis.
e Run the application without debugging to create a performance baseline.

e Configure the Microsoft Visual Studio* environment to download the debug information for system
libraries so that Amplifier can properly identify system functions and classify and attribute functions.

e Configure Visual Studio project properties to generate the debug information for your application
so that Amplifier can open the source code.

D NOTE. The steps below are provided for Microsoft Visual Studio* 2005. Steps for other
versions of Visual Studio IDE may slightly differ. See online help for more details.

Choose a Build Mode and Build a Target

1. Go to the Build > Configuration Manager... dialog box and select the Release mode for your
target project.

2. From the Visual Studio menu, select Build > Build analyze_locks.

The anal yze_| ocks application is built.

Create a Performance Baseline

1. From the Visual Studio menu, select Debug > Start Without Debugging.

The anal yze_| ocks application runs in multiple sections (depending on the number of CPUs in
your system).

D NOTE. Before you start the application, minimize the amount of other software running
on your computer to get more accurate results.
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M analyze locks.exe CPU Time: 32.641 seconds.

2. Note the execution time displayed in the window caption. For the anal yze_| ocks executable in
the figure above, the execution time is 32.641 seconds. The total execution time is the baseline
against which you will compare subsequent runs of the application.

u NOTE. Run the application several times, note the execution time for each run, and use
the average number. This helps to minimize skewed results due to transient system
activity.

65



3 Intel(R) Parallel Amplifier 2011 for Windows* OS Getting Started Tutorials

Enable Downloading the Debug Information for System Libraries

1. Go to Tools > Options....
The Options dialog box opens.
2. From the left pane, select Debugging > Symbols.

3.
In the Symbol file (.pdb) locations field, click the button and specify the following address:
http://msdl.microsoft.com/download/symbols.

4. Make sure the added address is checked.

5. In the Cache symbols from symbol servers to this directory field, specify a directory where
the downloaded symbol files will be stored.

6. For Microsoft* Visual Studio* 2005, check the Load symbols using the updated settings when
this dialog is closed box.

66



Intel® Parallel Amplifier Tutorial: Analyzing Locks and Waits 3

7. Click Ok.

Enable Generating Debug Information for Your Binary Files

1. Select the analyze_locks project and go to Project > Properties.

2. From the analyze_locks Property Pages dialog box, select Configuration Properties >
General and make sure the selected Configuration (top of the dialog) is Active(Release).

3. From the analyze_locks Property Pages dialog box, select C/C++ > General pane and specify
the Debug Information Format as Program Database (/Zi).
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4. From the analyze_locks Property Pages dialog box, select Linker > Debugging and set the
Generate Debug Info option to Yes (/DEBUG).

identify_concurrency Property Pages

Configuration: |Acﬁve(Re|ease} v | Platform: |#‘\Eﬁvef~""iﬂ32:' A | [ Configuration Manager... ]
- Commen Properties Generate Debug Info Yes (/DEBUG)
References Generate Program Database File &(TargetDir)&{TargetMame).pdb
= Configuration Properties Strip Private Symbols
General Generate Map File Mo
ngugging Map File Mame
C_,-'C++ Map Exports Mo
& Linker Debuggable Assembly Mo Debuggable attribute emitted
General
Input
Manifest File
System
Optimization
Embedded IDL
Adwanced
Command Line
Manifest Tool
XML Document Generator
Browse Information
Build Events
Custom Build Step
Web Deployment
Generate Debug Info
Enables generation of debug information.  {{DEBUG)
I oK l [ Cancel

Recap

You set up your environment to enable generating symbol information for system libraries and your
binary files, built the target in the Release mode, and created the performance baseline. Your
application is ready for analysis.

Key Terms and Concepts

e Term: target, baseline
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e Concept: Locks and Waits Analysis

Run Locks and Waits Analysis

After building the application, you can run it to analyze its performance. In this tutorial, you run the
Locks and Waits analysis to identify synchronization objects that caused contention and fix the
problem in the source.

To run an analysis:

1. From the Amplifier toolbar, select Locks and Waits — Where is my program waiting?

[E] Frofile |C0ncurrenc‘r' -Where is rr| vl B 01 3 §pcCompare

Solution Explorer - [ty 'J-;'hn_ere i 1y concurrency poor?
Hotspots - Where is my program spending time?

Lodks and Waits - Where is my program waiting?
2. Click the Profile button.

The Amplifier launches the anal yze | ocks executable that renders bal | s. dat as an input file,
calculates the execution time, and exits. The Amplifier finalizes the collected data and opens the
results in the Locks and Waits result tab.

D NOTE. To make sure the performance of the application is repeatable, go through the
entire tuning process on the same system with a minimal amount of other software
executing.
Recap

You ran the Locks and Waits data collection that analyzes how long the application had to wait on
each synchronization object, or in blocking APIs, such as sleep and blocking I/0, and estimates
processor utilization during the wait.

D NOTE. This tutorial explains how to run an analysis from the Amplifier graphical user
interface (GUI). You can also use the Amplifier command-line interface (anpl - cl
command) to run an analysis. For more details, check the Command-line Interface
Support section of the Amplifier Help.
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Key Terms and Concepts

e Concept: Locks and Waits Analysis, Finalization

Interpret Result Data

When the sample application exits, the Intel® Parallel Amplifier finalizes the results and opens the
Locks and Waits window displaying CPU time spent on synchronization objects used in your application.
Follow these steps to interpret the locks and waits data:

e Understand the basic performance metrics provided by the Locks and Waits analysis.
e Identify synchronization objects with high Wait time values and poor CPU utilization.

D NOTE. The screen shots and execution time data provided in this tutorial are created
on a system with two CPU cores. Your data may vary depending on the number and type
of CPU cores on your system.

Understand the Basic Locks and Waits Metrics

~r004hw | identify_concurrency.cpp - X
Locks and Waits

Sync Object Name Wait Time by Utilization:Self e Wait Creation Crestion 2
- Wait Function v Count:self | S¥nc Object Type | Creation Function | Creation Module Source File Linie.
LBl ATEE T [Dwe [l roor [Jok Wiceal [l over
&
B Auto Reset Event Oxab5120d4 36,464 (L 1079| Auto Reset Event | video::main_loop | tachyon_identify ... winvidea.h 243
E Critical Section Oxdaf1dfcg 23,163 I 472 | Critical Section thread_trace tachyon_identify ... |identify_conc ...| 205
[Sdraw_task: :operator() 28.163s I 2 472 | Critical Section thread_trace tachyon_identify ... |identify_conc ... | 205
T [TBE parallel_for on dass| 23, 163: (] 472 Critical Section thread_trace tachyon_identify ... |identify_conc ... | 205
HITBB Scheduler 10,063 3 2 Constant thread_trace tachyon_identify ... |identify_conc ... | 207
[#Sleep 1 10,243 4 556 | Constant [Unknown] [Unknown] [Unknown] [Unknown]
#Thread 0x029730 1 0.030s| 2| Thread video:tinit_window | tachyon_identify ... | gdivideo.cpp 111
[# Stream Ox3dffe2bl 0,000 | 8 | Stream thread_trace tachyon_identify ... |identify_conc ... | 207
[# Multiple Objects 0.0%6s | 184 Constant [Unknown] [Unknown] [Unknown] [Unknown]
Selected: 42.697s 2 v
SE £/ I3
w Wait Mndule: Wait Thread: | [All] hd | Utlizahon:| [l v| Process:| [Aall v| %
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Synchronization objects that control threads in the
application. The hash (unique number) appended to some
names of the objects identify the stack creating this
synchronization object.

For Intel® Threading Building Blocks (Intel® TBB), Amplifier
is able to recognize all types of Intel TBB objects. To
display an overhead introduced by Intel TBB library
internals, the Amplifier creates a pseudo synchronization
object TBB scheduler that includes all waits from the
Intel TBB runtime libraries.

The utilization of the processor time when a given thread
waited for some event to occur. By default, the
synchronization objects are sorted by Poor processor
utilization type. Bars showing OK or Ideal utilization
(orange and green) are utilizing the processors well. You
should focus your optimization efforts on functions with

the longest poor CPU utilization (red B bars if the bar
format is selected). Next, search for the longest

over-utilized time (blue . bars).

This is the Data of Interest column for the Locks and Waits
analysis results. This means that the data of this column
is used for different types of calculations, for example:
call stack contribution, percentage value on the filter
toolbar.

Number of times the corresponding system wait API was
called. For a lock, it is the number of times the lock was
contended and caused a wait. Usually you are
recommended to focus your tuning efforts on the waits
with both high Wait Time and Wait Count values,
especially if they have poor utilization.

Summary
@ Elapsed Time: 43,042
Wait Time: 127.8%44s
Wait Count: 2629
4 Unused CPU Time:  46.424s
Core Count: 2
Threads Created: 4
5

Concurrency

B summary |B] call Stack

Summary data on the application performance: 1) Elapsed Time is the execution time of
the application from start to termination; 2) Wait Time is the amount of time the application
threads waited for some event to occur, such as synchronization waits and I/O waits; 4)
Wait Count is the overall number of times the system wait API was called for the analyzed
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Identify Locks

application; 5) Unused CPU Time is the total time for each core when it was either waiting
or not utilized by the application; 6) Core Count is the logical CPU count for your machine;
5) Threads Created by your system during the application run.

Graph representing the Elapsed time and utilization level for the specified number of running
threads. Ideally, your graph nodes should be within the Ok or Ideal utilization range.

Note the Target Concurrency value. By default, this number is equal to the number of
physical cores. Consider this number as your optimization goal.

Average CPU Usage is calculated as CPU time / Elapsed time. Use this number as a baseline
for your performance measurements. The closer this number to the number of cores, the

better.

Start with analyzing the data provided in the Summary tab. The Summary tab shows that
tachyon_i dentify_concurrency. exe is a multithreaded application running three threads on a
machine with two cores. But it is not using available cores effectively. The Average CPU Usage on
the graph is about 1 while your target should be making it as closer to 2 as possible (for the system

with 2

cores).

For 35,370s the application had poor CPU utilization with 1
running or runnable thread(s).
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verage CPLU |

Hover over the second graph node to understand
how long the application ran serially. The tooltip
shows that the application ran one thread for almost
35 seconds, which is classified as Poor CPU
utilization.

Explore the Bottom-up window. You see that the
top three synchronization objects caused the longest
wait time. The red bars in the Wait Time by
Utilization column indicate that most of the time
for these objects processor cores were underutilized.

From the code knowledge, you may understand that
the first two objects are most likely related to the
join where the main program is waiting for the
worker threads to finish. This should not be a
problem. Consider the third item in the Bottom-up
window that is more interesting. It is a Critical
Section that shows much serial time and is causing

a wait. Click the plus sign *# at the object name to
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expand the node and see the dr aw_t ask wait
function that contains this critical section and Wait
Function Trees. Double-click the Critical Section to
see the source code for the wait function.

Recap

You identified a synchronization object with the high Wait Time and Wait Count values and poor CPU
utilization that could be a lock affecting application concurrency. Your next step is to analyze the
code of this function.

Key Terms and Concepts

e Term: Elapsed time, Wait time

e Concept: Locks and Waits Analysis, CPU Utilization, Data of Interest

Analyze Code

You identified the critical section that caused significant Wait time and poor processor utilization.
Double-click this critical section in the Bottom-up window to open the Source window and analyze
the source code:

e Understand basic options provided in the Source window.
e Identify the hottest code lines.
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Understand Basic Source View Options

r004hw

Line

identify_concurrency.cpp - X

Locks and Waits

ﬁ Bottom-up ﬁ Top-down Tree ¥ identify_concurren... X

E. 4
Source Wait Time by Utilization:Self w Wait i
Dide @Poor DOk @Idesl @ Over Count:Self
166| for (int y=r.begin(); y!=r.end(); ++¥] {
drawing_srea drawing(startx, totaly—y, stopx-startx, 1);

167

168

// Enter Criticel Section to protect pixel celculation from multithreaded access (Needed?)

EnterCriticalSection(&rgb critical section):

172 for (int x = startx; x < stopx; x++) { 1 2 3
173 -t o = render cne pimel (x, vy, loczl mbox, serizl, sStartx, StOpX, STarty, Stopyli
174 drawing.put_pixellc);
175
176
177 // Exit from the critical section
178 LeaveCriticalSecticn(srgb_critical_sectiocn);
179
Selected (1 row(s)): 28.163s 472 &
3 >
4 wWait Module:| [All] | Wait Thread:| [All] || Utilization: | [All] + | Process:| [all] v pa

The table below explains some of the features available in the Source window when viewing the
Locks and Waits analysis data.
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Source code of the application displayed if the function symbol information is available.
When you go to the source by double-clicking the synchronization object in the
Bottom-up window, the Amplifier opens the wait function containing this object and
highlights the code line that took the most Wait time. The source code in the Source
window is not editable.

If the function symbol information is not available, the Assembly window opens
displaying assembler instructions for the selected wait function. To enable the Source
view, make sure to build the target properly.

Processor time and utilization bar attributed to a particular code line. The colored bar
represents the distribution of the Wait time according to the Amplifier-defined utilization
levels (Idle, Poor, Ok, Ideal, and Over). The longer the bar, the higher the value. Ok
utilization level is not available for systems with a small number of cores.

This is the Data of Interest column for the Locks and Waits analysis.
Number of times the corresponding system wait API was called while this code line was

executing. For a lock, it is the number of times the lock was contended and caused a
wait.
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4 Source file editor button to open and edit your code in the Visual Studio editor.

Identify the Hottest Code Lines

The Amplifier highlights line 170 entering the critical section rgb_critical section in the

dr aw_t ask function. The dr aw_t ask function was waiting for almost 28 seconds while this code line
was executing and most of the time the processor was underutilized. During this time, the critical
section was contended 472 times.

Thergb_critical section isthe place where the application is serializing. Each thread has to
wait for the critical section to be available before it can proceed. Only one thread can be in the critical

section at a time. You need to optimize the code to make it more concurrent. Click the Source
Editor button on the Source window toolbar to open the code editor and work on optimizing the code.

Recap

You identified the code section that caused a significant wait and during which the processor was
poorly utilized.

Key Terms and Concepts

e Term: CPU time

e Concept: CPU Utilization, Locks and Waits Analysis, Data of Interest

Remove Lock

In the Source window, you located the critical section that caused a significant wait while the processor
cores were underutilized and generated multiple wait cout. Focus on this line and do the following:

e Open the code editor.
e Modify the code to remove the lock.

Open the Code Editor

Click the Source Editor button to open the anal yze_| ocks. cpp file in the Visual Studio editor
at the hotspot code line:

75



3 Intel(R) Parallel Amplifier 2011 for Windows* OS Getting Started Tutorials

% draw_task | |25 operator {const thbiblocked _range<int> &r) const v

163 unsigned int * local mbox = (unsigned int *) alloca(mboxsize): f

1 memset (local mbox, 0,mboxsize);

1 1):

169 on from multithreaded access (Needed?

172 for (int X = startx; X < sStopx; =x++) {

1 _t © = render_one pixel (x, y, local mbox, serial, startx, STLOpPX, Starty, Stopy);

1 drawing.put_pixel (c);

1 he critical section

178 ction(&rgkb critical section);

180 if(!video->next_Iframe ()} tbb::task::sell().cancel group_sxecutlon();

182

1341 draw_task () {}

128jp static void parallel thread (void) { 2
< b4

Remove the Lock

Thergb_critical _section was introduced to protect calculation from multithreaded access. The

brief analysis shows that the code is thread safe and the critical section is not really needed.

To resolve this issue:

D NOTE. The steps below are provided for Microsoft Visual Studio* 2005. Steps for other

versions of Visual Studio IDE may slightly differ. See online help for details.

1. Comment out code lines 170 and 178 to disable the critical section.
2. From Solution Explorer, select the analyze_locks project.
3. From Visual Studio menu, select Build > Rebuild analyze_locks.

The project is rebuilt.

4. From Visual Studio menu, select Debug > Start Without Debugging to run the application.

Visual Studio runs the anal yze_| ocks. exe. Note that execution time reduced from 32 seconds

to 19.5 seconds.
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M analyze locks.exe CPU Time: 19.547 seconds.

Recap

You optimized the application execution time by removing the unnecessary critical section that caused
a lot of Wait time.

Key Terms and Concepts

e Term: hotspot

e Concept: Locks and Waits Analysis
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Compare with Previous Result

You made sure that removing the critical section gave you 12.5 seconds of optimization in the
application execution time. To understand the impact of your changes and how the CPU utilization
has changed, re-run the Locks and Waits analysis on the optimized code and compare results:

e Compare results before and after optimization.
e Identify the performance gain.

Compare Results Before and After Optimization
1. Run the Locks and Waits analysis on the modified code.

2. Click the button on the Amplifier toolbar.

The Compare Results dialog box opens.

3. Specify the Locks and Waits analysis results you want to compare:

Compare results

Result 1: | r00<4w,ampl v| [Cerovee... |

Result 2: | r00Shw.ampl v| [ Erowse... |

These results can be compared. Click 'Compare' to continue

Swap Results

I Compare l [ Cancel ]

The Locks and Waits Bottom-up window opens, showing the list of synchronization objects used
in the code, Wait time utilization across the two results, and the differences side by side:
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between the two results in the following
format: <Difference Wait Time>
<Result 1 Wait Time> - <Result 2 Wait
Time>. By default, the Difference column
is expanded to display comparison data
per utilization level. You may collapse the
column to see the total difference data
per Wait time.

Wait count for the initial version of the
code.

Wait count for the optimized version of
the code.

ro04,~r004hw-r005hw [ identify_concurrency.cpp - X
Locks and Waits
§ Wait Time by < Wait Time by Utilization:Self: Wait Time by Utilization:Self:Difference Wait Wait i
sy_“.zgi‘tj]:;;g?o:e Utlization:Self: ro04w r005hw - Y Count:Self: | Count:Self: Count';éa\;"D\ﬁ =]
] Dide Mroor Dok @idesl Mide WPoor Dok Midesl I  Poorv | Ok | Ideal | Over rODHn 1005k rr
[#Critical Section Oxdafldfca 23.163s ] 0s 0s 25.244s Os 2918 0s 472 [ 472
B Auto Reset Event Oxab5120d4 36,969 Ol 15,559 1] 00185 23.770s 0s| -2.39%s 0s 1079 825 254
#Manual Reset Event 0x544507e6 | 42,697s O 32133 BBl  -0.017s 23.786s Os -0.437s -12.747s 2 2 0
[#5tream Oxan371203 0.001s | 0.003s | -0.002s  0.000s 0s s 0s 31 37 6
EThread Dxc17b3791 0.053s N 0.033s (- | 0.020s  0.000s s Os 0s 4 2 5 2 6 1]
B Auto Reset Event CTF. ThreadMI( 0.000s | 0= 0.000s 0= 3 s 0= Os 1 1] 1
E Auto Reset Event CTF. ThreadvIQ 0s 0.000s | -0.000s 1] o] Os 0s 0 1 -1
E Auto Reset Event CTF. ThreadMar| 0.000s | s 0.000s Os Os Os 0s 1 [1] 1
@ Auto Reset Event CTF. ThreadMar| 0s 0.000s | -0.000s 0s 0s Os 0= 0 1 -1
& Auto Reset Event MSCTF.SendRe 0.000s | 0.000s | -0.000s 0s Os Os s 13 13 1]
[#Auto Reset Event MSCTF.SendRe|  0.004s | 0.000s | 0.004s 0s s s s 13 13 0
HIME Msgs 0s 0.002s | -0.002s Os Os Os Os 0 2 -2
[#Message Ox3efe36ds s 0,000s | -0.000s s Os Os s 0 1 -1
inknown Oxe735211h 0.000s | 0.000s | 0.000s Os 0s Os 0Os 7 7 0
utex CTF. TimListCache.FMPDefz 0.000s | 0s 0.000s 0s Os Os s 1 1] 1
B Selected: 28.163s Os 25.244 Os| 2.918s s 472 a 472|8
= I %
% |Filter: 100% is shown | wait Modu\e:l [All v | Wait Thread:‘ [all v‘ Unhzanon:| [Al] v | Process:l [Al] vl 3%
Wait time and CPU utilization for the initial  [summary -1 x
version of the code. 004w  rO0S  Diff.
i
Elapsed Time: 43,0425 32,5425 10,5008
Wait time and CPU utilization for the Wait Time: 127.844s 70,3055 57.539s
optimized version of the code i o ot o e 52
p . Logical CPUs Utilized: 092 1.30  -0.38
Unused CPU Time: 46.424s 22.817s 23.608s
Difference in Wait time per utilization level Core Count: 2 2 0
Threads Created: 4 0
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6 Difference in Wait count between the two
results in the following format:
<Difference Wait Count> = <Results 1
Wait Count> - <Result 2 Wait Count>.

7 Comparison summary data for the two results and their difference calculated as r004lw -
ro05lw= Diff.

Logical CPUs Utilized is the average utilization of all cores during application run.

8 Concurrency graphs for both compared results.

Identify the Performance Gain

In the Bottom-up window, locate the Critical Section you identified as a bottleneck in your code.
Since you removed it during optimization, the optimized result r005Iw does not show any performance
data for this synchronization object. If you collapse the Wait Time:Difference column by clicking
the [ button, you see that with the optimized result you got almost 28 seconds of optimization in
Wait time.

The Elapsed time data in the Summary tab shows the optimization of 10.5 seconds for the whole
application execution and Wait time decreased by 57 seconds. According to the concurrency graph
in the Summary tab, before optimization the application ran serially for the most of the time poorly
utlizing available two processor cores but after optimization it ran multiple threads (two to three)
most of the time, sometimes overutilizing the cores.

Recap

You ran the Locks and Waits analysis on the optimized code and compared the results before and
after optimization using the Compare mode of the Amplifier . The comparison shows that, with the
optimized version of the t achyon_anal yze_| ocks application (rO05Iw result), you managed to
effectively utilize all available cores and got 10.5-second speedup for the application Elapsed time.
Compare analysis results regularly to look for regressions and to track how incremental changes to
the code affect its performance. You may also want to use the Amplifier command-line interface and
run the anpl - cI command to test your code for regressions. For more details, see the Command-line
Interface Support section in the Amplifier online help.

Key Terms and Concepts

e Term: hotspot, Wait time, Elapsed time
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Concept: Locks and Waits Analysis, CPU Utilization

Summary

You have completed the Analyzing Locks and Waits tutorial. Here are some important things to
remember when using the Amplifier to analyze your code for locks and waits:

Step 1. Choose and Build Your Target

Configure the Microsoft* symbol server and your project properties to get the most accurate
results for system and user binaries and to analyze the performance of your application at the
code line level.

Create a performance baseline to compare the application versions before and after optimization.
Make sure to use the same workload for each application run.

Step 2. Run Analysis

Use the Amplifier toolbar or Tools menu to choose and run the analysis. You can also use the
anmpl - cl command.

If required, modify the default analysis settings from Tools > Options... > Intel Parallel
Amplifier 2011 > Collection. For example, you may limit the data collection to a predefined
amount of data or enable the Amplifier to collect more accurate CPU time data.

Step 3. Interpret Results and Resolve the Issue

Start analyzing the performance of your application from the Summary tab to explore the
performance metrics for the whole application. Then, move to the Bottom-up window to analyze
the synchronization objects. Focus on the synchronization objects that under- or over-utilized the
available logical CPUs and have the highest Wait time and Wait Count values. By default, the
objects with the highest Wait time values show up at the top of the window.

Expand the most time-critical synchronization object in the Bottom-up window and double-click
the wait function it belongs to. This opens the source code for this wait function at the code line
with the highest Wait time value.
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Step 4. Compare Results Before and After Optimization

e Perform regular regression testing by comparing analysis results before and after optimization.

From GUI, click the Compare Results button on the Amplifier toolbar. From command line,
use the anpl - ¢l command.

e Expand each data column by clicking thel button to identify the performance gain per CPU
utilization level.
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Getting Help and Support

Intel® Parallel Amplifier provides a number of Getting Started tutorials. These tutorials use a sample
application to demo you the basic product features and workflows. You can access these documents from

Microsoft Visual Studio* environment either through the Help menu or by clicking the Amplifier icon &,

From the Visual Studio user interface, select Help > Intel Parallel Studio 2011 > Getting Started >
Amplifier Tutorials and explore available tutorials.

Browsing Help
In the Visual Studio IDE, you can browse and search for topics in different ways:

e Use Help > Contents to open the Contents window and browse the Table of Contents.

e To view help for an installed Parallel Studio tool, select Help > Intel Parallel Studio 2011 > Parallel
Studio Help > Amplifier Help.

e Use Help > Index to open the Index window and access an index to Amplifier topics. Either type in
the keyword you are looking for, or scroll through the list of keywords.

e Use Help > Search to open the Search page and search the full text of topics in the help.

Locating Intel Topics in the Document Explorer

To filter the documentation so that only the Intel documentation appears, select Help > Contents from
the Visual Studio user interface. In the Filtered by: drop-down list, select Intel.

To determine where the currently displayed topic appears in the table of contents (TOC), click the %)
Sync with Table of Contents button on the Visual Studio toolbar to highlight the topic in the Contents
pane.

Navigating in the Product Usage Workflow

Where applicable, the Amplifier help topics provide a E’B@ Where am I in the workflow? button. Click
the button to view the workflow with a highlight on the stage that this topic discusses.
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Activating Intel Search Filters in the Document Explorer

With Microsoft Visual Studio 2005 and 2008, you can include Intel documentation in all search results
by checking the Intel search filter box for the Language, Technology, and Content Type categories.
You must check the Intel search box for all three categories to include Intel documentation in your
searches. Unchecking all three Intel search boxes excludes Intel documentation from search results.
The Intel search filters work in combination with other search options for each category.

Using Context-Sensitive Help

Context-sensitive help enables easy access to help topics on active GUI elements. The following
context-sensitive help features are available on a product-specific basis:

e ? Help: In Visual Studio, click the ? button, in the upper-right corner of the dialog box or pane
to get help for the dialog box or pane.

e F1 Help: Press F1 to get help for an active dialog box, property page, pane, or window.

e Dynamic Help: In Visual Studio 2005/2008, select Help > Dynamic Help to open the Dynamic
Help window, which displays links to relevant help topics for the current window.

System Requirements

For detailed information on system requirements, see the product Release Notes.

Product Support

Product Website and Support

The following links provide information and support on Intel software products, including Intel®
Parallel Studio:

e http://www.intel.com/software/products/
At this site, you will find comprehensive product information, including:

e Links to each product, where you will find technical information such as white papers and
articles

e Links to user forums

e Links to news and events
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e http://software.intel.com/en-us/articles/intel-parallel-studio/

Intel® Software Network, Parallel Studio Support page, with links to support forums, startup help,
knowledge base, and getting started video.

e http://software.intel.com/en-us/articles/tools/
Intel® Software Development Products Knowledge Base.
e http://www.intel.com/software/products/support/

Technical support information, to register your product, or to contact Intel.

For additional support information, see the Technical Support section of your Release Notes.

System Requirements

For detailed information on system requirements, see the Release Notes.
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